summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2018-08-14 01:37:17 +0200
committerGitHub <noreply@github.com>2018-08-14 01:37:17 +0200
commit2820f92554cbce52afdab3710413e26975cddd5e (patch)
treecaf8388e17cce225cd3ce592f765ed0200569c2e /setup.py
parent5bd44f8afcecbfb0db479ce230c790fc2c56569a (diff)
downloadpsutil-2820f92554cbce52afdab3710413e26975cddd5e.tar.gz
OSX / SMC / sensors: revert #1284 (#1325)
* setup.py: add py 3.7 * Revert OSX sensors code due to copyright constraints It turns out code contributed in PR #1284 was using parts of a source code released by Apple [1] which uses GPL license which is incompatible with psutil's license (BSD). [1] https://gist.github.com/edvakf/4049362
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index adc7a0e2..c4845a8d 100755
--- a/setup.py
+++ b/setup.py
@@ -152,7 +152,6 @@ elif MACOS:
sources=sources + [
'psutil/_psutil_osx.c',
'psutil/arch/osx/process_info.c',
- 'psutil/arch/osx/smc.c',
],
define_macros=macros,
extra_link_args=[
@@ -322,6 +321,7 @@ def main():
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Programming Language :: Python',