summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-02-13 13:21:54 -0800
committerGiampaolo Rodola <g.rodola@gmail.com>2020-02-13 13:21:54 -0800
commit573886fa81db2c4b0ae9d296fa0fe1ac9055f3f8 (patch)
treeaf5e4cd391951570340176ff43c912696c5df46c /setup.py
parentf0b87e1f7dc6f666bd48e26b7a1f84975d7b09b8 (diff)
downloadpsutil-573886fa81db2c4b0ae9d296fa0fe1ac9055f3f8.tar.gz
#1672: warning pre-processor directive don't work on win + py2; also if struct.calcsize('l') < 8 assume int
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e7c69316..76c4ddba 100755
--- a/setup.py
+++ b/setup.py
@@ -56,7 +56,7 @@ if BSD:
# Needed to determine _Py_PARSE_PID in case it's missing (Python 2, PyPy).
# Taken from Lib/test/test_fcntl.py.
# XXX: not bullet proof as the (long long) case is missing.
-if struct.calcsize('l') == 8:
+if struct.calcsize('l') <= 8:
macros.append(('PSUTIL_SIZEOF_PID_T', '4')) # int
else:
macros.append(('PSUTIL_SIZEOF_PID_T', '8')) # long