summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2018-05-04 23:43:46 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2018-05-04 23:43:46 +0200
commit6ad33123e00383f9ea8a3e336783acec27c30448 (patch)
tree4d2d9e0077bf4374c006007912b5c736af870d9a /setup.py
parent757f16b744a8b8d8ae442cf69732feff02e83ea8 (diff)
downloadpsutil-6ad33123e00383f9ea8a3e336783acec27c30448.tar.gz
minor refactoring
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index d8db694e..fffefd2f 100755
--- a/setup.py
+++ b/setup.py
@@ -43,8 +43,6 @@ from _common import AIX # NOQA
macros = []
if POSIX:
macros.append(("PSUTIL_POSIX", 1))
-if WINDOWS:
- macros.append(("PSUTIL_WINDOWS", 1))
if BSD:
macros.append(("PSUTIL_BSD", 1))
@@ -117,6 +115,7 @@ if WINDOWS:
msg += "Visual Studio and may also (kind of) work though"
warnings.warn(msg, UserWarning)
+ macros.append(("PSUTIL_WINDOWS", 1))
macros.extend([
# be nice to mingw, see:
# http://www.mingw.org/wiki/Use_more_recent_defined_functions
@@ -252,6 +251,7 @@ elif AIX:
'psutil/arch/aix/ifaddrs.c'],
libraries=['perfstat'],
define_macros=macros)
+
else:
sys.exit('platform %s is not supported' % sys.platform)