summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLucas Holt <luke@foolishgames.com>2021-11-19 16:04:29 -0500
committerGitHub <noreply@github.com>2021-11-19 22:04:29 +0100
commit875d2195fc8efa642c7bca714d468551d1805c6c (patch)
tree7403c1c85cad988d01966a2f10cc73f202a10489 /setup.py
parent7fa22e8b8510e2bcf03694204ada1ee7be82e477 (diff)
downloadpsutil-875d2195fc8efa642c7bca714d468551d1805c6c.tar.gz
Handle missing dependencies on MidnightBSD (#2019)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 16b476f2..90ae5170 100755
--- a/setup.py
+++ b/setup.py
@@ -424,7 +424,10 @@ def main():
print(hilite("XCode (https://developer.apple.com/xcode/) "
"is not installed"), color="red", file=sys.stderr)
elif FREEBSD:
- missdeps("pkg install gcc python%s" % py3)
+ if which('pkg'):
+ missdeps("pkg install gcc python%s" % py3)
+ elif which('mport'): # MidnightBSD
+ missdeps("mport install gcc python%s" % py3)
elif OPENBSD:
missdeps("pkg_add -v gcc python%s" % py3)
elif NETBSD: