summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-05-05 11:16:25 -0700
committerGiampaolo Rodola <g.rodola@gmail.com>2020-05-05 11:16:25 -0700
commit8ad353bc515d7765e7dc3dfaaa8f9f6db4f85aba (patch)
treebc7f0d5834fc43ace1f4b6113859e73f2da353e4 /setup.py
parent15b35646d95b617b04a2e556f1b0902d3f64c3cb (diff)
downloadpsutil-8ad353bc515d7765e7dc3dfaaa8f9f6db4f85aba.tar.gz
fix some memleak tests on win
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 2402a143..19153bda 100755
--- a/setup.py
+++ b/setup.py
@@ -113,9 +113,9 @@ def silenced_output(stream_name):
def missdeps(msg):
- s = hilite("C compiler or Python headers are not installed ", ok=False)
- s += hilite("on this system. Try to run:\n", ok=False)
- s += hilite(msg, ok=False, bold=True)
+ s = hilite("C compiler or Python headers are not installed ", color="red")
+ s += hilite("on this system. Try to run:\n", color="red")
+ s += hilite(msg, color="red", bold=True)
print(s, file=sys.stderr)
@@ -402,7 +402,7 @@ def main():
missdeps("sudo yum install gcc python%s-devel" % py3)
elif MACOS:
print(hilite("XCode (https://developer.apple.com/xcode/) "
- "is not installed"), ok=False, file=sys.stderr)
+ "is not installed"), color="red", file=sys.stderr)
elif FREEBSD:
missdeps("pkg install gcc python%s" % py3)
elif OPENBSD:
@@ -419,7 +419,7 @@ def main():
ur = "http://www.microsoft.com/en-us/download/"
ur += "details.aspx?id=44266"
s = "VisualStudio is not installed; get it from %s" % ur
- print(hilite(s, ok=False), file=sys.stderr)
+ print(hilite(s, color="red"), file=sys.stderr)
if __name__ == '__main__':