summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-03-09 19:51:10 -0800
committerGiampaolo Rodola <g.rodola@gmail.com>2018-03-09 19:51:10 -0800
commitb578d2febfd35f80fcfa1ce1bdf18d44d21b1581 (patch)
tree5341acf84032ee89457b973d3c0fd24f332c4db4 /setup.py
parentb409472c271c0f803cfa8ecc83033e508f2ae429 (diff)
downloadpsutil-b578d2febfd35f80fcfa1ce1bdf18d44d21b1581.tar.gz
Move tests out of package to top level directory (#1232)
Cleanly separates tests from the package itself. Prevents the tests being installed to site-packages. Tests are still distributed with the source distribution by MANIFEST.in. Avoids installing tests in production environments, leading to less total code in the environment.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 61056f5f..f03ab457 100755
--- a/setup.py
+++ b/setup.py
@@ -279,7 +279,7 @@ def main():
url='https://github.com/giampaolo/psutil',
platforms='Platform Independent',
license='BSD',
- packages=['psutil', 'psutil.tests'],
+ packages=['psutil'],
ext_modules=extensions,
# see: python setup.py register --list-classifiers
classifiers=[
@@ -327,7 +327,7 @@ def main():
if setuptools is not None:
kwargs.update(
python_requires=">=2.6, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
- test_suite="psutil.tests.get_suite",
+ test_suite="tests.get_suite",
tests_require=[
'ipaddress; python_version < "3.3"',
'mock; python_version < "3.3"',