summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-01-13 00:30:16 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2020-01-13 00:30:16 +0100
commitbab3a310ab561bfdd01d44b1d2121daac7469e8f (patch)
treefa4acebc1cadc1a4295c96a322269bd68eb532be /setup.py
parent0b21b19fb2ef008d3cdb9a82e494b1a024a5c14b (diff)
downloadpsutil-bab3a310ab561bfdd01d44b1d2121daac7469e8f.tar.gz
update setup.py classifiers
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py13
1 files changed, 11 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 37af746a..774d566a 100755
--- a/setup.py
+++ b/setup.py
@@ -331,7 +331,6 @@ def main():
license='BSD',
packages=['psutil', 'psutil.tests'],
ext_modules=extensions,
- # see: python setup.py register --list-classifiers
classifiers=[
'Development Status :: 5 - Production/Stable',
'Environment :: Console',
@@ -341,9 +340,16 @@ def main():
'Intended Audience :: System Administrators',
'License :: OSI Approved :: BSD License',
'Operating System :: MacOS :: MacOS X',
- 'Operating System :: Microsoft :: Windows :: Windows NT/2000',
+ 'Operating System :: Microsoft :: Windows :: Windows 10',
+ 'Operating System :: Microsoft :: Windows :: Windows 7',
+ 'Operating System :: Microsoft :: Windows :: Windows 8',
+ 'Operating System :: Microsoft :: Windows :: Windows 8.1',
+ 'Operating System :: Microsoft :: Windows :: Windows Server 2003',
+ 'Operating System :: Microsoft :: Windows :: Windows Server 2008',
+ 'Operating System :: Microsoft :: Windows :: Windows Vista',
'Operating System :: Microsoft',
'Operating System :: OS Independent',
+ 'Operating System :: POSIX :: AIX',
'Operating System :: POSIX :: BSD :: FreeBSD',
'Operating System :: POSIX :: BSD :: NetBSD',
'Operating System :: POSIX :: BSD :: OpenBSD',
@@ -362,11 +368,14 @@ def main():
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Software Development :: Libraries',
'Topic :: System :: Benchmark',
+ 'Topic :: System :: Hardware :: Hardware Drivers',
'Topic :: System :: Hardware',
'Topic :: System :: Monitoring',
+ 'Topic :: System :: Networking :: Monitoring :: Hardware Watchdog',
'Topic :: System :: Networking :: Monitoring',
'Topic :: System :: Networking',
'Topic :: System :: Operating System',
+ 'Topic :: System :: Power (UPS)'
'Topic :: System :: Systems Administration',
'Topic :: Utilities',
],