summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--HISTORY.rst2
-rw-r--r--docs/index.rst4
-rwxr-xr-xpsutil/tests/test_misc.py2
3 files changed, 7 insertions, 1 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index ae2a584e..7ee1f930 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -3,7 +3,7 @@
5.9.0 (IN DEVELOPMENT)
======================
-XXXX-XX-XX
+2021-12-29
**Enhancements**
diff --git a/docs/index.rst b/docs/index.rst
index 47b53b51..2ac9c2ce 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -2610,6 +2610,10 @@ Supported Python versions are 2.6, 2.7, 3.4+ and PyPy3.
Timeline
========
+- 2021-12-29:
+ `5.9.0 <https://pypi.org/project/psutil/5.9.0/#files>`__ -
+ `what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#590>`__ -
+ `diff <https://github.com/giampaolo/psutil/compare/release-5.8.0...release-5.9.0#files_bucket>`__
- 2020-12-19:
`5.8.0 <https://pypi.org/project/psutil/5.8.0/#files>`__ -
`what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#580>`__ -
diff --git a/psutil/tests/test_misc.py b/psutil/tests/test_misc.py
index 0362432c..d946eb62 100755
--- a/psutil/tests/test_misc.py
+++ b/psutil/tests/test_misc.py
@@ -366,6 +366,8 @@ class TestMisc(PsutilTestCase):
check(psutil.disk_usage(os.getcwd()))
check(psutil.users())
+ # XXX: https://github.com/pypa/setuptools/pull/2896
+ @unittest.skipIf(APPVEYOR, "temporarily disabled due to setuptools bug")
def test_setup_script(self):
setup_py = os.path.join(ROOT_DIR, 'setup.py')
if CI_TESTING and not os.path.exists(setup_py):