summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in16
-rw-r--r--psutil/_psutil_windows.c2
-rw-r--r--psutil/arch/windows/cpu.c2
-rw-r--r--psutil/arch/windows/disk.c2
-rw-r--r--psutil/arch/windows/globals.c (renamed from psutil/arch/windows/global.c)2
-rw-r--r--psutil/arch/windows/globals.h (renamed from psutil/arch/windows/global.h)0
-rw-r--r--psutil/arch/windows/net.c2
-rw-r--r--psutil/arch/windows/process_handles.c2
-rw-r--r--psutil/arch/windows/process_info.c2
-rw-r--r--psutil/arch/windows/process_utils.c2
-rw-r--r--psutil/arch/windows/socks.c2
-rwxr-xr-xsetup.py2
12 files changed, 22 insertions, 14 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index d26c2d74..75ad5f15 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -64,19 +64,27 @@ include psutil/arch/solaris/environ.c
include psutil/arch/solaris/environ.h
include psutil/arch/solaris/v10/ifaddrs.c
include psutil/arch/solaris/v10/ifaddrs.h
-include psutil/arch/windows/global.c
-include psutil/arch/windows/global.h
-include psutil/arch/windows/inet_ntop.c
-include psutil/arch/windows/inet_ntop.h
+include psutil/arch/windows/cpu.c
+include psutil/arch/windows/cpu.h
+include psutil/arch/windows/disk.c
+include psutil/arch/windows/disk.h
+include psutil/arch/windows/globals.c
+include psutil/arch/windows/globals.h
+include psutil/arch/windows/net.c
+include psutil/arch/windows/net.h
include psutil/arch/windows/ntextapi.h
include psutil/arch/windows/process_handles.c
include psutil/arch/windows/process_handles.h
include psutil/arch/windows/process_info.c
include psutil/arch/windows/process_info.h
+include psutil/arch/windows/process_utils.c
+include psutil/arch/windows/process_utils.h
include psutil/arch/windows/security.c
include psutil/arch/windows/security.h
include psutil/arch/windows/services.c
include psutil/arch/windows/services.h
+include psutil/arch/windows/socks.c
+include psutil/arch/windows/socks.h
include psutil/arch/windows/wmi.c
include psutil/arch/windows/wmi.h
include psutil/tests/README.rst
diff --git a/psutil/_psutil_windows.c b/psutil/_psutil_windows.c
index ec8b0b2a..b5d1b4ec 100644
--- a/psutil/_psutil_windows.c
+++ b/psutil/_psutil_windows.c
@@ -28,7 +28,7 @@
#pragma comment(lib, "IPHLPAPI.lib")
#include "arch/windows/ntextapi.h"
-#include "arch/windows/global.h"
+#include "arch/windows/globals.h"
#include "arch/windows/security.h"
#include "arch/windows/process_utils.h"
#include "arch/windows/process_info.h"
diff --git a/psutil/arch/windows/cpu.c b/psutil/arch/windows/cpu.c
index e891dcc8..b44f6c0c 100644
--- a/psutil/arch/windows/cpu.c
+++ b/psutil/arch/windows/cpu.c
@@ -9,7 +9,7 @@
#include <PowrProf.h>
#include "ntextapi.h"
-#include "global.h"
+#include "globals.h"
#include "../../_psutil_common.h"
diff --git a/psutil/arch/windows/disk.c b/psutil/arch/windows/disk.c
index 821f687d..cb36c0b3 100644
--- a/psutil/arch/windows/disk.c
+++ b/psutil/arch/windows/disk.c
@@ -9,7 +9,7 @@
#include <tchar.h>
#include "ntextapi.h"
-#include "global.h"
+#include "globals.h"
#include "../../_psutil_common.h"
diff --git a/psutil/arch/windows/global.c b/psutil/arch/windows/globals.c
index 1aafcdd1..50505102 100644
--- a/psutil/arch/windows/global.c
+++ b/psutil/arch/windows/globals.c
@@ -11,7 +11,7 @@
#include <windows.h>
#include <Python.h>
#include "ntextapi.h"
-#include "global.h"
+#include "globals.h"
// Needed to make these globally visible.
diff --git a/psutil/arch/windows/global.h b/psutil/arch/windows/globals.h
index 6764dde0..6764dde0 100644
--- a/psutil/arch/windows/global.h
+++ b/psutil/arch/windows/globals.h
diff --git a/psutil/arch/windows/net.c b/psutil/arch/windows/net.c
index 92887f42..271ac06a 100644
--- a/psutil/arch/windows/net.c
+++ b/psutil/arch/windows/net.c
@@ -13,7 +13,7 @@
#include <ws2tcpip.h>
#include "ntextapi.h"
-#include "global.h"
+#include "globals.h"
static PIP_ADAPTER_ADDRESSES
diff --git a/psutil/arch/windows/process_handles.c b/psutil/arch/windows/process_handles.c
index 04b30f11..1b4b3db7 100644
--- a/psutil/arch/windows/process_handles.c
+++ b/psutil/arch/windows/process_handles.c
@@ -10,7 +10,7 @@
#include <Python.h>
#include "ntextapi.h"
-#include "global.h"
+#include "globals.h"
#include "process_utils.h"
CRITICAL_SECTION g_cs;
diff --git a/psutil/arch/windows/process_info.c b/psutil/arch/windows/process_info.c
index 757cabbe..1c7174f5 100644
--- a/psutil/arch/windows/process_info.c
+++ b/psutil/arch/windows/process_info.c
@@ -11,7 +11,7 @@
#include <windows.h>
#include "ntextapi.h"
-#include "global.h"
+#include "globals.h"
#include "process_utils.h"
#include "../../_psutil_common.h"
diff --git a/psutil/arch/windows/process_utils.c b/psutil/arch/windows/process_utils.c
index 1a721ba5..e10c7f5c 100644
--- a/psutil/arch/windows/process_utils.c
+++ b/psutil/arch/windows/process_utils.c
@@ -11,7 +11,7 @@
#include <Psapi.h> // EnumProcesses
#include "ntextapi.h"
-#include "global.h"
+#include "globals.h"
#include "process_utils.h"
#include "../../_psutil_common.h"
diff --git a/psutil/arch/windows/socks.c b/psutil/arch/windows/socks.c
index 854ca955..50d29687 100644
--- a/psutil/arch/windows/socks.c
+++ b/psutil/arch/windows/socks.c
@@ -12,7 +12,7 @@
#include <ws2tcpip.h>
#include "ntextapi.h"
-#include "global.h"
+#include "globals.h"
#include "process_utils.h"
#include "../../_psutil_common.h"
diff --git a/setup.py b/setup.py
index 9e63db68..8c82ad0c 100755
--- a/setup.py
+++ b/setup.py
@@ -150,7 +150,7 @@ if WINDOWS:
'psutil/arch/windows/cpu.c',
'psutil/arch/windows/security.c',
'psutil/arch/windows/services.c',
- 'psutil/arch/windows/global.c',
+ 'psutil/arch/windows/globals.c',
'psutil/arch/windows/socks.c',
'psutil/arch/windows/wmi.c',
],