summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--appveyor.yml62
-rw-r--r--make.bat4
3 files changed, 36 insertions, 32 deletions
diff --git a/Makefile b/Makefile
index 64ffaeb3..e33d30a9 100644
--- a/Makefile
+++ b/Makefile
@@ -37,7 +37,7 @@ build: clean
$(PYTHON) setup.py build_ext -i
# useful deps which are nice to have while developing / testing
-install-dev-deps:
+setup-dev-env:
python -c "import urllib2; \
r = urllib2.urlopen('https://bootstrap.pypa.io/get-pip.py'); \
open('/tmp/get-pip.py', 'w').write(r.read());"
diff --git a/appveyor.yml b/appveyor.yml
index b23d2c1a..6f001f7a 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -14,35 +14,39 @@ environment:
PYTHON_VERSION: "2.7.x"
PYTHON_ARCH: "32"
- # - PYTHON: "C:\\Python33"
- # PYTHON_VERSION: "3.3.x"
- # PYTHON_ARCH: "32"
-
- # - PYTHON: "C:\\Python34"
- # PYTHON_VERSION: "3.4.x"
- # PYTHON_ARCH: "32"
-
- # - PYTHON: "C:\\Python27-x64"
- # PYTHON_VERSION: "2.7.x"
- # PYTHON_ARCH: "64"
- # WINDOWS_SDK_VERSION: "v7.0"
-
- # - PYTHON: "C:\\Python33-x64"
- # PYTHON_VERSION: "3.3.x"
- # PYTHON_ARCH: "64"
- # WINDOWS_SDK_VERSION: "v7.1"
-
- # - PYTHON: "C:\\Python34-x64"
- # PYTHON_VERSION: "3.4.x"
- # PYTHON_ARCH: "64"
- # WINDOWS_SDK_VERSION: "v7.1"
-
- # # Also build on a Python version not pre-installed by Appveyor.
- # # See: https://github.com/ogrisel/python-appveyor-demo/issues/10
-
- # - PYTHON: "C:\\Python266"
- # PYTHON_VERSION: "2.6.6"
- # PYTHON_ARCH: "32"
+ - PYTHON: "C:\\Python33"
+ PYTHON_VERSION: "3.3.x"
+ PYTHON_ARCH: "32"
+
+ - PYTHON: "C:\\Python34"
+ PYTHON_VERSION: "3.4.x"
+ PYTHON_ARCH: "32"
+
+ - PYTHON: "C:\\Python27-x64"
+ PYTHON_VERSION: "2.7.x"
+ PYTHON_ARCH: "64"
+ WINDOWS_SDK_VERSION: "v7.0"
+
+ - PYTHON: "C:\\Python33-x64"
+ PYTHON_VERSION: "3.3.x"
+ PYTHON_ARCH: "64"
+ WINDOWS_SDK_VERSION: "v7.1"
+
+ - PYTHON: "C:\\Python34-x64"
+ PYTHON_VERSION: "3.4.x"
+ PYTHON_ARCH: "64"
+ WINDOWS_SDK_VERSION: "v7.1"
+
+ # Also build on a Python version not pre-installed by Appveyor.
+ # See: https://github.com/ogrisel/python-appveyor-demo/issues/10
+
+ - PYTHON: "C:\\Python322"
+ PYTHON_VERSION: "3.2.6"
+ PYTHON_ARCH: "32"
+
+ - PYTHON: "C:\\Python266"
+ PYTHON_VERSION: "2.6.6"
+ PYTHON_ARCH: "32"
init:
- "ECHO %PYTHON% %PYTHON_VERSION% %PYTHON_ARCH%"
diff --git a/make.bat b/make.bat
index c6e0dd05..9c430101 100644
--- a/make.bat
+++ b/make.bat
@@ -50,7 +50,7 @@ if "%1" == "help" (
echo clean clean build files
echo flake8 run flake8
echo install compile and install
- echo setup-env install pip, unittest2, wheels for all python versions
+ echo setup-dev-env install pip, pywin32, wheels, etc. for all python versions
echo test run tests
echo test-memleaks run memory leak tests
echo test-process run process related tests
@@ -161,7 +161,7 @@ if "%1" == "upload-all" (
goto :eof
)
-if "%1" == "setup-env" (
+if "%1" == "setup-dev-env" (
:setup-env
@echo ------------------------------------------------
@echo downloading pip installer