summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile6
-rw-r--r--docs/index.rst1
2 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a3075012..dc18e62e 100644
--- a/Makefile
+++ b/Makefile
@@ -197,7 +197,7 @@ check-imports: ## Run isort linter.
check-c-code: ## Run C linter.
@git ls-files '*.c' '*.h' | xargs $(PYTHON) scripts/internal/clinter.py
-lint: ## Run all linters
+check-all: ## Run all linters
${MAKE} check-flake8
${MAKE} check-imports
${MAKE} check-c-code
@@ -213,6 +213,10 @@ fix-flake8: ## Run autopep8, fix some Python flake8 / pep8 issues.
fix-imports: ## Fix imports with isort.
@git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg
+fix-all:
+ ${MAKE} fix-flake8
+ ${MAKE} fix-imports
+
# ===================================================================
# GIT
# ===================================================================
diff --git a/docs/index.rst b/docs/index.rst
index 7cf673ef..045ba83b 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -2597,6 +2597,7 @@ If you want to develop psutil take a look at the `development guide`_.
Platforms support history
=========================
+* psutil 5.9.1 (2022-XX): drop Python 2.6 support
* psutil 5.9.0 (2021-12): **MidnightBSD**
* psutil 5.8.0 (2020-12): **PyPy 2** on Windows
* psutil 5.7.1 (2020-07): **Windows Nano**