summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4910c13e..8954e72f 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@ TSCRIPT = psutil/tests/runner.py
# Internal.
DEPS = \
- autoflake \
+ git+https://github.com/PyCQA/autoflake.git@refs/pull/107/head \
autopep8 \
check-manifest \
concurrencytest \
@@ -213,7 +213,7 @@ lint-all: ## Run all linters
fix-flake8: ## Run autopep8, fix some Python flake8 / pep8 issues.
@git ls-files '*.py' | xargs $(PYTHON) -m autopep8 --in-place --jobs 0 --global-config=.flake8
- @git ls-files '*.py' | xargs $(PYTHON) -m autoflake --in-place --remove-all-unused-imports --remove-unused-variables
+ @git ls-files '*.py' | xargs $(PYTHON) -m autoflake --in-place --jobs 0 --remove-all-unused-imports --remove-unused-variables --remove-duplicate-keys
fix-imports: ## Fix imports with isort.
@git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg