summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml13
1 files changed, 2 insertions, 11 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 7f3b43d5..435cc989 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -42,8 +42,8 @@ build-backend = "setuptools.build_meta"
skip = ["pp*", "*-musllinux*"]
test-extras = "test"
test-command = [
- "PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_DEBUG=1 python {project}/psutil/tests/runner.py",
- "PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_DEBUG=1 python {project}/psutil/tests/test_memleaks.py"
+ "env PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_DEBUG=1 PSUTIL_SCRIPTS_DIR={project}/scripts python {project}/psutil/tests/runner.py",
+ "env PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_DEBUG=1 PSUTIL_SCRIPTS_DIR={project}/scripts python {project}/psutil/tests/test_memleaks.py"
]
[tool.cibuildwheel.macos]
@@ -54,12 +54,3 @@ archs = ["x86_64", "arm64"]
# restrict build & tests to cp36
# cp36-abi3 wheels will need to be tested outside cibuildwheel for python>=3.7
build = "cp36-*"
-test-command = [
- "python {project}/psutil/tests/runner.py",
- "python {project}/psutil/tests/test_memleaks.py"
-]
-
-[tool.cibuildwheel.windows.environment]
-PYTHONWARNINGS = "always"
-PYTHONUNBUFFERED = "1"
-PSUTIL_DEBUG = "1"