summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 16b476f2..90ae5170 100755
--- a/setup.py
+++ b/setup.py
@@ -424,7 +424,10 @@ def main():
print(hilite("XCode (https://developer.apple.com/xcode/) "
"is not installed"), color="red", file=sys.stderr)
elif FREEBSD:
- missdeps("pkg install gcc python%s" % py3)
+ if which('pkg'):
+ missdeps("pkg install gcc python%s" % py3)
+ elif which('mport'): # MidnightBSD
+ missdeps("mport install gcc python%s" % py3)
elif OPENBSD:
missdeps("pkg_add -v gcc python%s" % py3)
elif NETBSD: