summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-10-19 11:49:40 +0100
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-10-19 11:49:40 +0100
commitab49fc79aa3b4fd9fe477fde427ae4144f82255d (patch)
tree997952b626f5d97931b12d65129c318de1e7f971
parent0f986c00d834ff1a50af5f28da3fc797fae87f8a (diff)
downloadpsycopg2-fix-604.tar.gz
Test building PG 10 using the solution provided by Jason Ericksonfix-604
https://github.com/psycopg/psycopg2-wheels/pull/3/
-rw-r--r--.appveyor.yml19
1 files changed, 13 insertions, 6 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 6871cb4..b41e7ef 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -73,6 +73,9 @@ matrix:
fast_finish: false
services:
+ # Note: if you change this service also change the path to match in:
+ # - the postgresql.conf customisation in 'init'
+ # - the path in 'build_script'
- postgresql96
cache:
@@ -173,8 +176,7 @@ install:
CALL ms\%DO% &&
nmake -f ms\nt.mak init headers lib &&
COPY inc32\openssl\*.h %OPENSSLTOP%\include\openssl &&
- COPY out32\libeay32.lib %OPENSSLTOP%\lib\libeay32MD.lib &&
- COPY out32\ssleay32.lib %OPENSSLTOP%\lib\ssleay32MD.lib &&
+ COPY out32\*.lib %OPENSSLTOP%\lib &&
CD %BASE_DIR% &&
RMDIR /S /Q %BUILD_DIR%\openssl-OpenSSL_1_0_2l
)
@@ -193,8 +195,10 @@ install:
)
# Setup build config file (config.pl)
- # Build libpgport first
- # Build libpq
+ # Hack the Mkvcbuild.pm file so we build the lib version of libpq
+ # Build libpgport, libpgcommon, libpq
+ # Copy over includes
+ # Copy over built libraries
# NOTE: Cannot set and use the same variable inside an IF
- SET PGBUILD=%BUILD_DIR%\postgres-REL_10_0
- IF NOT EXIST %PGTOP%\lib\libpq.lib (
@@ -205,11 +209,14 @@ install:
ECHO $config-^>{openssl} = "%OPENSSLTOP:\=\\%"; >> config.pl &&
ECHO.>> config.pl &&
ECHO 1;>> config.pl &&
+ perl -pi.bak -e "s/'libpq', 'dll'/'libpq', 'lib'/g" Mkvcbuild.pm &&
build libpgport &&
+ build libpgcommon &&
build libpq &&
XCOPY /E ..\..\include %PGTOP%\include &&
COPY %PGBUILD%\Release\libpgport\libpgport.lib %PGTOP%\lib &&
- COPY %PGBIULD%\Release\libpq\libpq.lib %PGTOP%\lib &&
+ COPY %PGBUILD%\Release\libpgcommon\libpgcommon.lib %PGTOP%\lib &&
+ COPY %PGBUILD%\Release\libpq\libpq.lib %PGTOP%\lib &&
CD %BASE_DIR% &&
RMDIR /S /Q %PGBUILD%
)
@@ -222,7 +229,7 @@ build_script:
# Add PostgreSQL binaries to the path
- PATH=C:\Program Files\PostgreSQL\9.6\bin\;%PATH%
- CD C:\Project
- - "%PYTHON%\\python.exe setup.py build_ext --have-ssl -l libpgcommon -L %OPENSSLTOP%\\lib;%PGTOP%\\lib -I %OPENSSLTOP%\\include;%PGTOP%\\include"
+ - "%PYTHON%\\python.exe setup.py build_ext --have-ssl -l libpgcommon -l libpgport -L %OPENSSLTOP%\\lib;%PGTOP%\\lib -I %OPENSSLTOP%\\include;%PGTOP%\\include"
- "%PYTHON%\\python.exe setup.py build"
- "%PYTHON%\\python.exe setup.py install"