summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFederico Di Gregorio <fog@initd.org>2010-12-01 21:55:42 +0100
committerFederico Di Gregorio <fog@initd.org>2010-12-01 21:55:42 +0100
commit5f80dd38c41d099ab1936f529a6eb06b078eb667 (patch)
tree52a659db20b71ebdfdfae31588de4dcfddd41c30 /Makefile
parenta411f853546835c09e1c871252d485614c1bdec0 (diff)
downloadpsycopg2-5f80dd38c41d099ab1936f529a6eb06b078eb667.tar.gz
Removed runtests target; checks is the default for Makefiles
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index 8ebbcd7..e73b5f6 100644
--- a/Makefile
+++ b/Makefile
@@ -16,11 +16,7 @@
#
# Run the test::
#
-# make check # but this requires setting up a test database with the correct user)
-#
-# or
-#
-# make runtests # requires the TESTDB in place
+# make check # this requires setting up a test database with the correct user
PYTHON := python$(PYTHON_VERSION)
PYTHON_VERSION ?= $(shell $(PYTHON) -c 'import sys; print "%d.%d" % sys.version_info[:2]')
@@ -68,10 +64,6 @@ docs-txt: doc/psycopg2.txt
sdist: $(SDIST)
-runtests: package
- PYTHONPATH=$(BUILD_DIR):.:$(PYTHONPATH) $(PYTHON) tests/__init__.py --verbose
-
-
# The environment is currently required to build the documentation.
# It is not clean by 'make clean'
@@ -90,8 +82,7 @@ ez_setup:
wget -O $(EZ_SETUP) http://peak.telecommunity.com/dist/ez_setup.py
check:
- $(MAKE) testdb
- $(MAKE) runtests
+ PYTHONPATH=$(BUILD_DIR):.:$(PYTHONPATH) $(PYTHON) tests/__init__.py --verbose
testdb:
@echo "* Creating $(TESTDB)"