summaryrefslogtreecommitdiff
path: root/doc/src
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2020-08-24 01:44:45 +0100
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2020-08-24 01:48:31 +0100
commit82d679cdb33e83ea52522618616d502d06707347 (patch)
tree74802a3dfd86d8a4234032bd90d9ab859368654c /doc/src
parent9c30fdbc63a4c791949e977d41e6ca4e23404e3e (diff)
downloadpsycopg2-82d679cdb33e83ea52522618616d502d06707347.tar.gz
A few corrections to the install page
Spacing, lines length, a spurious link targed, reST formatting.
Diffstat (limited to 'doc/src')
-rw-r--r--doc/src/install.rst22
1 files changed, 9 insertions, 13 deletions
diff --git a/doc/src/install.rst b/doc/src/install.rst
index 53798d7..ee845f7 100644
--- a/doc/src/install.rst
+++ b/doc/src/install.rst
@@ -22,14 +22,17 @@ wrapper for the libpq_, the official PostgreSQL client library.
Quick Install
-------------
-For most operating systems, the quickest way to install psycopg is using the wheel_ package available on PyPI_:
+For most operating systems, the quickest way to install Psycopg is using the
+wheel_ package available on PyPI_:
.. code-block:: console
$ pip install psycopg2-binary
-This will install a pre-compiled binary version of the module which does not require the build or runtime prerequisites described below. Make sure to use an up-date-date version of :program:`pip` (you can upgrade it
-using something like ``pip install -U pip``).
+This will install a pre-compiled binary version of the module which does not
+require the build or runtime prerequisites described below. Make sure to use
+an up-date-date version of :program:`pip` (you can upgrade it using something
+like ``pip install -U pip``).
You may then import the ``psycopg`` package, as usual:
@@ -49,10 +52,10 @@ You may then import the ``psycopg`` package, as usual:
# Retrieve query results
records = cur.fetchall()
-.. __: PyPI-binary_
.. _PyPI: https://pypi.org/project/psycopg2-binary/
.. _wheel: https://pythonwheels.com/
+
psycopg vs psycopg-binary
^^^^^^^^^^^^^^^^^^^^^^^^^
@@ -61,10 +64,9 @@ with Python and PostgreSQL without the need to meet the build
requirements.
If you are the maintainer of a published package depending on `!psycopg2`
-you shouldn't use 'psycopg2-binary' as a module dependency. **For
+you shouldn't use ``psycopg2-binary`` as a module dependency. **For
production use you are advised to use the source distribution.**
-
The binary packages come with their own versions of a few C libraries,
among which ``libpq`` and ``libssl``, which will be used regardless of other
libraries available on the client: upgrading the system libraries will not
@@ -81,7 +83,6 @@ source if you want to maintain binary upgradeability.
advised to use a package built from source.
-
.. index::
single: Install; disable wheel
single: Wheel; disable
@@ -219,10 +220,6 @@ which is OS-dependent (for instance setting a suitable
to connect to.
-
-
-
-
.. index::
single: setup.py
single: setup.cfg
@@ -335,7 +332,6 @@ setting the environment variables:
The database should already exist before running the tests.
-
.. _other-problems:
If you still have problems
@@ -360,4 +356,4 @@ Try the following. *In order:*
:envvar:`ARCHFLAGS`. Especially useful from the Starbucks near you.
.. _mailing list: https://www.postgresql.org/list/psycopg/
-.. _bug tracker: https://github.com/psycopg/psycopg2/issues \ No newline at end of file
+.. _bug tracker: https://github.com/psycopg/psycopg2/issues