summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in2
-rw-r--r--Makefile9
2 files changed, 3 insertions, 8 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 66fc265..0d34fd3 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -8,4 +8,4 @@ recursive-include doc/src *.rst *.py *.css Makefile
recursive-include scripts *.py *.sh
include scripts/maketypes.sh scripts/buildtypes.py
include AUTHORS README.rst INSTALL LICENSE NEWS
-include PKG-INFO MANIFEST.in MANIFEST setup.py setup.cfg Makefile
+include MANIFEST.in setup.py setup.cfg Makefile
diff --git a/Makefile b/Makefile
index 232f0d0..a8f491e 100644
--- a/Makefile
+++ b/Makefile
@@ -92,14 +92,9 @@ $(PACKAGE)/tests/%.py: tests/%.py
$(PYTHON) setup.py build_py $(BUILD_OPT)
touch $@
-$(SDIST): MANIFEST $(SOURCE)
+$(SDIST): $(SOURCE)
$(PYTHON) setup.py sdist $(SDIST_OPT)
-MANIFEST: MANIFEST.in $(SOURCE)
- # Run twice as MANIFEST.in includes MANIFEST
- $(PYTHON) setup.py sdist --manifest-only
- $(PYTHON) setup.py sdist --manifest-only
-
# docs depend on the build as it partly use introspection.
doc/html/genindex.html: $(PLATLIB) $(PURELIB) $(SOURCE_DOC)
$(MAKE) -C doc html
@@ -111,5 +106,5 @@ doc/docs.zip: doc/html/genindex.html
(cd doc/html && zip -r ../docs.zip *)
clean:
- rm -rf build MANIFEST
+ rm -rf build
$(MAKE) -C doc clean