summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--NEWS52
-rw-r--r--ZPsycopgDA/DA.py2
-rw-r--r--psycopg2.cproj4
-rw-r--r--psycopg2.sln23
-rw-r--r--setup.py2
5 files changed, 43 insertions, 40 deletions
diff --git a/NEWS b/NEWS
index b9e5397..a7e634e 100644
--- a/NEWS
+++ b/NEWS
@@ -3,12 +3,12 @@ What's new in psycopg 2.4
* New features and changes:
- - Added support for Python 3.1 and 3.2. The conversion has also brought
- several improvements:
+ - Added support for Python 3.1 and 3.2. The conversion has also
+ brought several improvements:
- - Added 'b' and 't' mode to large objects: write can deal with both bytes
- strings and unicode; read can return either bytes strings or decoded
- unicode.
+ - Added 'b' and 't' mode to large objects: write can deal with both
+ bytes strings and unicode; read can return either bytes strings
+ or decoded unicode.
- COPY sends Unicode data to files implementing 'io.TextIOBase'.
- Improved PostgreSQL-Python encodings mapping.
- Added a few missing encodings: EUC_CN, EUC_JIS_2004, ISO885910,
@@ -17,40 +17,42 @@ What's new in psycopg 2.4
- Improvements to the named cusors:
- - More efficient iteration on named cursors, fetching 'itersize' records at
- time from the backend.
+ - More efficient iteration on named cursors, fetching 'itersize'
+ records at time from the backend.
- The named cursors name can be an invalid identifier.
- Improvements in data handling:
- - Added 'register_composite()' function to cast PostgreSQL composite types
- into Python tuples/namedtuples.
- - Adapt types 'bytearray' (from Python 2.6), 'memoryview' (from Python 2.7)
- and other objects implementing the "Revised Buffer Protocol" to 'bytea'
- data type.
- - The 'hstore' adapter can work even when the data type is not installed
- in the 'public' namespace.
- - Raise a clean exception instead of returning bad data when receiving bytea
- in 'hex' format and the client libpq can't parse them.
+ - Added 'register_composite()' function to cast PostgreSQL
+ composite types into Python tuples/namedtuples.
+ - Adapt types 'bytearray' (from Python 2.6), 'memoryview' (from
+ Python 2.7) and other objects implementing the "Revised Buffer
+ Protocol" to 'bytea' data type.
+ - The 'hstore' adapter can work even when the data type is not
+ installed in the 'public' namespace.
+ - Raise a clean exception instead of returning bad data when
+ receiving bytea in 'hex' format and the client libpq can't parse
+ them.
- Empty lists correctly roundtrip Python -> PostgreSQL -> Python.
- Other changes:
- 'cursor.description' is provided as named tuples if available.
- - The build script refuses to guess values if 'pg_config' is not found.
+ - The build script refuses to guess values if 'pg_config' is not
+ found.
- Connections and cursors are weakly referenceable.
* Bug fixes:
- - Fixed adaptation of None in composite types (ticket #26). Bug report by
- Karsten Hilbert.
+ - Fixed adaptation of None in composite types (ticket #26). Bug
+ report by Karsten Hilbert.
- Fixed several reference leaks in less common code paths.
- - Fixed segfault when a large object is closed and its connection no more
- available.
- - Added missing icon to ZPsycopgDA package, not available in Zope 2.12.9
- (ticket #30). Bug report and patch by Pumukel.
- - Fixed conversion of negative infinity (ticket #40). Bug report and patch
- by Marti Raudsepp.
+ - Fixed segfault when a large object is closed and its connection no
+ more available.
+ - Added missing icon to ZPsycopgDA package, not available in Zope
+ 2.12.9 (ticket #30). Bug report and patch by Pumukel.
+ - Fixed conversion of negative infinity (ticket #40). Bug report and
+ patch by Marti Raudsepp.
What's new in psycopg 2.3.2
diff --git a/ZPsycopgDA/DA.py b/ZPsycopgDA/DA.py
index 4cdecae..8635ec5 100644
--- a/ZPsycopgDA/DA.py
+++ b/ZPsycopgDA/DA.py
@@ -16,7 +16,7 @@
# their work without bothering about the module dependencies.
-ALLOWED_PSYCOPG_VERSIONS = ('2.4-beta1', '2.4-beta2')
+ALLOWED_PSYCOPG_VERSIONS = ('2.4-beta1', '2.4-beta2', '2.4')
import sys
import time
diff --git a/psycopg2.cproj b/psycopg2.cproj
index f6f2cbd..22cc3d8 100644
--- a/psycopg2.cproj
+++ b/psycopg2.cproj
@@ -89,7 +89,6 @@
<None Include="psycopg\microprotocols.h" />
<None Include="psycopg\microprotocols_proto.h" />
<None Include="psycopg\pgtypes.h" />
- <None Include="psycopg\pgversion.h" />
<None Include="psycopg\pqpath.h" />
<None Include="psycopg\psycopg.h" />
<None Include="psycopg\python.h" />
@@ -198,12 +197,11 @@
<None Include="psycopg\green.h" />
<None Include="doc\src\pool.rst" />
<None Include="sandbox\dec2float.py" />
- <None Include="NEWS-2.0" />
<None Include="psycopg\notify.h" />
<None Include="psycopg\xid.h" />
<None Include="tests\dbapi20_tpc.py" />
<None Include="tests\test_cursor.py" />
- <None Include="NEWS-2.3" />
+ <None Include="NEWS" />
</ItemGroup>
<ItemGroup>
<Compile Include="psycopg\adapter_asis.c" />
diff --git a/psycopg2.sln b/psycopg2.sln
index aed4f21..c2ddba9 100644
--- a/psycopg2.sln
+++ b/psycopg2.sln
@@ -19,19 +19,22 @@ Global
Policies = $0
$0.TextStylePolicy = $1
$1.FileWidth = 120
- $1.NoTabsAfterNonTabs = False
+ $1.TabWidth = 4
+ $1.inheritsSet = Mono
+ $1.inheritsScope = text/plain
$0.DotNetNamingPolicy = $2
$2.DirectoryNamespaceAssociation = None
$2.ResourceNamePolicy = FileName
- $0.TextStylePolicy = $3
- $3.NoTabsAfterNonTabs = False
- $3.inheritsSet = Mono
- $3.inheritsScope = text/x-python
- $3.scope = text/plain
- $0.StandardHeader = $4
- $4.Text =
- $4.IncludeInNewFiles = False
- $4.inheritsSet = MITX11License
+ $0.StandardHeader = $3
+ $3.Text =
+ $3.IncludeInNewFiles = False
+ $0.TextStylePolicy = $4
+ $4.FileWidth = 72
+ $4.NoTabsAfterNonTabs = True
+ $4.RemoveTrailingWhitespace = True
+ $4.inheritsSet = VisualStudio
+ $4.inheritsScope = text/plain
+ $4.scope = text/x-readme
name = psycopg2
EndGlobalSection
EndGlobal
diff --git a/setup.py b/setup.py
index e87c78d..c626d8f 100644
--- a/setup.py
+++ b/setup.py
@@ -79,7 +79,7 @@ except ImportError:
# Take a look at http://www.python.org/dev/peps/pep-0386/
# for a consistent versioning pattern.
-PSYCOPG_VERSION = '2.4-beta3'
+PSYCOPG_VERSION = '2.4'
version_flags = ['dt', 'dec']