summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in2
-rw-r--r--README38
-rw-r--r--README.rst44
-rw-r--r--psycopg2.cproj2
4 files changed, 46 insertions, 40 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 1aa0ef4..58aa51a 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -6,5 +6,5 @@ recursive-include doc README HACKING SUCCESS COPYING.LESSER pep-0249.txt
recursive-include doc/src *.rst *.py *.css Makefile
recursive-include scripts *.py *.sh
include scripts/maketypes.sh scripts/buildtypes.py
-include AUTHORS README INSTALL LICENSE NEWS
+include AUTHORS README.rst INSTALL LICENSE NEWS
include PKG-INFO MANIFEST.in MANIFEST setup.py setup.cfg Makefile
diff --git a/README b/README
deleted file mode 100644
index 7466bf9..0000000
--- a/README
+++ /dev/null
@@ -1,38 +0,0 @@
-psycopg2 - Python-PostgreSQL Database Adapter
-********************************************
-
-psycopg2 is a PostgreSQL database adapter for the Python programming
-language. psycopg2 was written with the aim of being very small and fast,
-and stable as a rock.
-
-psycopg2 is different from the other database adapter because it was
-designed for heavily multi-threaded applications that create and destroy
-lots of cursors and make a conspicuous number of concurrent INSERTs or
-UPDATEs. psycopg2 also provides full asynchronous operations and support
-for coroutine libraries.
-
-psycopg2 can compile and run on Linux, FreeBSD, Solaris, MacOS X and
-Windows architecture. It supports Python versions from 2.4 onwards and
-PostgreSQL versions from 7.4 onwards.
-
-psycopg2 is free software ("free as in freedom" but I like beer too.)
-It is licensed under the GNU Lesser General Public License, version 3 or
-later plus an exception to allow OpenSSL (libpq) linking; see LICENSE for
-more details.
-
-Documentation
--------------
-
-Start by reading the INSTALL file. More information about psycopg2 extensions
-to the DBAPI-2.0 is available in the files located in the doc/ direcory.
-Example code can be found in the examples/ directory. If you make any changes
-to the code make sure to run the unit tests localed in tests/.
-
-Online documentation can be found at: http://initd.org/psycopg/
-
-If you stumble upon any bugs, please tell us at: http://psycopg.lighthouseapp.com/
-
-Contributors
-------------
-
-For a list of contributors to the project, see the AUTHORS file.
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..d83d2d4
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,44 @@
+psycopg2 - Python-PostgreSQL Database Adapter
+=============================================
+
+Psycopg is the most popular PostgreSQL database adapter for the Python
+programming language. Its main features are the complete implementation of
+the Python DB API 2.0 specification and the thread safety (several threads can
+share the same connection). It was designed for heavily multi-threaded
+applications that create and destroy lots of cursors and make a large number
+of concurrent "INSERT"s or "UPDATE"s.
+
+Psycopg 2 is mostly implemented in C as a libpq wrapper, resulting in being
+both efficient and secure. It features client-side and server-side cursors,
+asynchronous communication and notifications, "COPY TO/COPY FROM" support.
+Many Python types are supported out-of-the-box and adapted to matching
+PostgreSQL data types; adaptation can be extended and customized thanks to a
+flexible objects adaptation system.
+
+Psycopg 2 is both Unicode and Python 3 friendly.
+
+
+Documentation
+-------------
+
+Documentation is included in the 'doc' directory and is `available online`__.
+
+.. __: http://initd.org/psycopg/docs/
+
+
+Installation
+------------
+
+If all the dependencies are met (i.e. you have the Python and libpq
+development packages installed in your system) the standard::
+
+ python setup.py build
+ sudo python setup.py install
+
+should work no problem. In case you have any problem check the 'install' and
+the 'faq' documents in the docs or online.
+
+For any other resource (source code repository, bug tracker, mailing list)
+please check the `project homepage`__.
+
+.. __: http://initd.org/psycopg/
diff --git a/psycopg2.cproj b/psycopg2.cproj
index 1640ab1..42cfca9 100644
--- a/psycopg2.cproj
+++ b/psycopg2.cproj
@@ -44,7 +44,7 @@
<None Include="INSTALL" />
<None Include="LICENSE" />
<None Include="MANIFEST.in" />
- <None Include="README" />
+ <None Include="README.rst" />
<None Include="setup.cfg" />
<None Include="setup.py" />
<None Include="doc\HACKING" />