summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsk Solem <ask@celeryproject.org>2016-04-06 11:42:45 -0700
committerAsk Solem <ask@celeryproject.org>2016-04-06 11:42:45 -0700
commitb50591f777122f3fe6d43d117a52f6d4fb423a2b (patch)
tree3fa332662284441b0ec6aa512def2eb2f17c2faa
parent5017199afb1ba2b853763e503f7046a870549ab5 (diff)
downloadpy-amqp-b50591f777122f3fe6d43d117a52f6d4fb423a2b.tar.gz
Use unicode_literals for all files, and updates flakeplus target to --2.7
-rw-r--r--Makefile2
-rw-r--r--docs/_ext/applyxrefs.py1
-rw-r--r--docs/_ext/literals_to_xrefs.py1
-rw-r--r--docs/conf.py1
-rwxr-xr-xextra/release/bump_version.py3
-rwxr-xr-xextra/release/sphinx-to-rst.py2
-rw-r--r--extra/update_comments_from_spec.py2
-rw-r--r--requirements/pkgutils.txt2
-rw-r--r--setup.py1
-rw-r--r--tox.ini12
10 files changed, 21 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 73f122e..6dbd872 100644
--- a/Makefile
+++ b/Makefile
@@ -34,7 +34,7 @@ flakediag:
-$(MAKE) flakecheck
flakepluscheck:
- flakeplus amqp --2.6
+ flakeplus --2.7 amqp
flakeplusdiag:
-$(MAKE) flakepluscheck
diff --git a/docs/_ext/applyxrefs.py b/docs/_ext/applyxrefs.py
index a9a9d8c..8d1e812 100644
--- a/docs/_ext/applyxrefs.py
+++ b/docs/_ext/applyxrefs.py
@@ -1,4 +1,5 @@
"""Adds xref targets to the top of files."""
+from __future__ import absolute_import, unicode_literals
import sys
import os
diff --git a/docs/_ext/literals_to_xrefs.py b/docs/_ext/literals_to_xrefs.py
index 41aa616..7903f16 100644
--- a/docs/_ext/literals_to_xrefs.py
+++ b/docs/_ext/literals_to_xrefs.py
@@ -2,6 +2,7 @@
Runs through a reST file looking for old-style literals, and helps replace them
with new-style references.
"""
+from __future__ import absolute_import, unicode_literals
import re
import sys
diff --git a/docs/conf.py b/docs/conf.py
index 7bb8d1b..95a2892 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -1,4 +1,5 @@
# -*- coding: utf-8 -*-
+from __future__ import absolute_import, unicode_literals
import sys
import os
diff --git a/extra/release/bump_version.py b/extra/release/bump_version.py
index 87bb6bd..738d9b8 100755
--- a/extra/release/bump_version.py
+++ b/extra/release/bump_version.py
@@ -1,6 +1,5 @@
#!/usr/bin/env python
-
-from __future__ import absolute_import
+from __future__ import absolute_import, unicode_literals
import errno
import os
diff --git a/extra/release/sphinx-to-rst.py b/extra/release/sphinx-to-rst.py
index e0c1fd0..10ce6c8 100755
--- a/extra/release/sphinx-to-rst.py
+++ b/extra/release/sphinx-to-rst.py
@@ -1,4 +1,6 @@
#!/usr/bin/env python
+from __future__ import absolute_import, unicode_literals
+
import os
import re
import sys
diff --git a/extra/update_comments_from_spec.py b/extra/update_comments_from_spec.py
index e8a99d8..f13601a 100644
--- a/extra/update_comments_from_spec.py
+++ b/extra/update_comments_from_spec.py
@@ -1,4 +1,4 @@
-from __future__ import absolute_import
+from __future__ import absolute_import, unicode_literals
import os
import sys
diff --git a/requirements/pkgutils.txt b/requirements/pkgutils.txt
index 75f5f8d..593449d 100644
--- a/requirements/pkgutils.txt
+++ b/requirements/pkgutils.txt
@@ -1,4 +1,4 @@
flake8
-flakeplus
+flakeplus>=1.1
tox
Sphinx-PyPI-upload
diff --git a/setup.py b/setup.py
index 6594b15..1ed971b 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
+from __future__ import absolute_import, unicode_literals
try:
from setuptools import setup, find_packages
diff --git a/tox.ini b/tox.ini
index b601b42..f82dcd3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = 2.7,pypy,3.4,3.5,pypy3
+envlist = 2.7,pypy,3.4,3.5,pypy3,flakeplus,flake8
[testenv]
deps=
@@ -24,3 +24,13 @@ basepython =
deps = -r{toxinidir}/requirements/docs.txt
commands =
sphinx-build -W -b linkcheck -d {envtmpdir}/doctrees docs docs/_build/linkcheck
+
+[testenv:flake8]
+deps = -r{toxinidir}/requirements/pkgutils.txt
+commands =
+ flake8 {toxinidir}/amqp
+
+[testenv:flakeplus]
+deps = -r{toxinidir}/requirements/pkgutils.txt
+commands =
+ flakeplus --2.6 {toxinidir}/amqp