summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsif Saif Uddin <auvipy@gmail.com>2021-12-13 12:37:47 +0600
committerGitHub <noreply@github.com>2021-12-13 12:37:47 +0600
commitb992496c756ea0415f4f2b1ee17004f0f97aa3e8 (patch)
tree968158f94e70ca88f9a3d8deca715acd1d620eb6
parentd4c879f03e84e00bad9bd54cb8bf3c8b18bcd0f6 (diff)
downloadpy-amqp-b992496c756ea0415f4f2b1ee17004f0f97aa3e8.tar.gz
add new python versions to tox (#366)
* add new python versions to tox * added codeql actions * drop as we dont use travis * added tidelift alignment action * Adding two tests, for Connection.collect and Transport.close. * revert 3.6 removal * update classifier * reorganize CI process and aded new python versions * remove python 3.10 from CI actions for now Co-authored-by: VinayGValsaraj <vinaygvalsaraj@gmail.com>
-rw-r--r--.github/workflows/ci.yaml54
-rw-r--r--setup.py2
-rw-r--r--tox.ini6
3 files changed, 34 insertions, 28 deletions
diff --git a/.github/workflows/ci.yaml b/.github/workflows/ci.yaml
index 5e1e85a..bf944c8 100644
--- a/.github/workflows/ci.yaml
+++ b/.github/workflows/ci.yaml
@@ -1,35 +1,13 @@
name: CI
on: [pull_request, push]
jobs:
- #################### Linters and checkers ####################
- lint:
- runs-on: ubuntu-latest
- strategy:
- matrix:
- python-version: [3.8]
- steps:
- - name: Check out code from GitHub
- uses: actions/checkout@v2.3.4
- - name: Set up Python ${{ matrix.python-version }}
- id: python
- uses: actions/setup-python@v2.2.1
- with:
- python-version: ${{ matrix.python-version }}
- - name: Install dependencies
- run: pip install --upgrade pip setuptools wheel tox tox-docker
- - name: Run flake8
- run: tox -v -e py-flake8 -- -v
- - name: Run pydocstyle
- run: tox -v -e py-pydocstyle -- -v
- - name: Run apicheck
- run: tox -v -e py-apicheck -- -v
+
#################### Unittests ####################
unittest:
- needs: lint
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.6,3.7,3.8,pypy3]
+ python-version: [3.6,3.7,3.8,3.9,pypy3]
steps:
- name: Check out code from GitHub
uses: actions/checkout@v2.3.4
@@ -44,11 +22,11 @@ jobs:
run: tox -v -e ${{ matrix.python-version }}-unit -- -v
#################### Integration tests ####################
integration:
- needs: [lint, unittest]
+ needs: [unittest]
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.6,3.7,3.8,pypy3]
+ python-version: [3.6,3.7,3.8,3.9,pypy3]
steps:
- name: Check out code from GitHub
uses: actions/checkout@v2.3.4
@@ -68,3 +46,27 @@ jobs:
CELERY_ENABLE_SPEEDUPS=1 python setup.py develop
tox -v -e ${{ matrix.python-version }}-integration-rabbitmq -- -v
if: ${{ matrix.python-version != 'pypy3'}}
+
+ #################### Linters and checkers ####################
+ lint:
+ needs: [unittest, integration]
+ runs-on: ubuntu-latest
+ strategy:
+ matrix:
+ python-version: [3.8]
+ steps:
+ - name: Check out code from GitHub
+ uses: actions/checkout@v2.3.4
+ - name: Set up Python ${{ matrix.python-version }}
+ id: python
+ uses: actions/setup-python@v2.2.1
+ with:
+ python-version: ${{ matrix.python-version }}
+ - name: Install dependencies
+ run: pip install --upgrade pip setuptools wheel tox tox-docker
+ - name: Run flake8
+ run: tox -v -e py-flake8 -- -v
+ - name: Run pydocstyle
+ run: tox -v -e py-pydocstyle -- -v
+ - name: Run apicheck
+ run: tox -v -e py-apicheck -- -v
diff --git a/setup.py b/setup.py
index 4224142..5616bdc 100644
--- a/setup.py
+++ b/setup.py
@@ -20,6 +20,8 @@ classes = """
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
+ Programming Language :: Python :: 3.9
+ Programming Language :: Python :: 3.10
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: Implementation :: PyPy
License :: OSI Approved :: BSD License
diff --git a/tox.ini b/tox.ini
index bbb1f34..6fd950e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
envlist =
- {pypy3,3.6,3.7,3.8}-unit
- {pypy3,3.6,3.7,3.8}-integration-rabbitmq
+ {pypy3,3.6,3.7,3.8,3.9,3.10}-unit
+ {pypy3,3.6,3.7,3.8,3.9.3.10}-integration-rabbitmq
flake8
flakeplus
apicheck
@@ -27,6 +27,8 @@ basepython =
3.6: python3.6
3.7: python3.7
3.8: python3.8
+ 3.9: python3.9
+ 3.10: python3.10
install_command = python -m pip --disable-pip-version-check install {opts} {packages}
commands_pre =
integration-rabbitmq: ./wait_for_rabbitmq.sh