summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2019-10-19 23:20:40 -0400
committerPaul Kehrer <paul.l.kehrer@gmail.com>2019-10-20 11:20:40 +0800
commit92fd05271fa95b0f118866ccd374cd355fcc1baf (patch)
tree71b44a949d158ebd8ee8e92580761f03e3d98dd7
parentdd4ca13821224ca925cfbdd13ffe8b8fb1df481a (diff)
downloadpy-bcrypt-git-92fd05271fa95b0f118866ccd374cd355fcc1baf.tar.gz
Fixes #187 -- test and build wheels on py38 (#188)
* Fixes #187 -- test and build wheels on py38 * Remove 3.8 for now * Tell tox to use isolated builds
-rw-r--r--.azure-pipelines/wheel-builder.yml8
-rw-r--r--.travis.yml8
-rw-r--r--azure-pipelines.yml8
-rw-r--r--setup.py1
-rw-r--r--tox.ini3
5 files changed, 27 insertions, 1 deletions
diff --git a/.azure-pipelines/wheel-builder.yml b/.azure-pipelines/wheel-builder.yml
index ce70093..c2057bb 100644
--- a/.azure-pipelines/wheel-builder.yml
+++ b/.azure-pipelines/wheel-builder.yml
@@ -143,6 +143,14 @@ jobs:
containerImage: 'pyca/cryptography-runner-windows:py3-x86_64'
PYTHON_VERSION: '37'
WINDOWS_ARCH: 'x86_64'
+ Python38-x86:
+ containerImage: 'pyca/cryptography-runner-windows:py3-x86'
+ PYTHON_VERSION: '38'
+ WINDOWS_ARCH: 'x86'
+ Python38-x86-64:
+ containerImage: 'pyca/cryptography-runner-windows:py3-x86_64'
+ PYTHON_VERSION: '38'
+ WINDOWS_ARCH: 'x86_64'
steps:
- script: '"C:/Python%PYTHON_VERSION%/python.exe" -m pip install -U pip==10.0.1'
displayName: Downgrade pip lol
diff --git a/.travis.yml b/.travis.yml
index 0956ee2..16e83e4 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -18,6 +18,10 @@ matrix:
env: TOXENV=py37 CC=gcc
dist: xenial
sudo: true
+ - python: 3.8
+ env: TOXENV=py38 CC=gcc
+ dist: xenial
+ sudo: true
- python: pypy
env: TOXENV=pypy CC=gcc
- python: 2.7
@@ -32,6 +36,10 @@ matrix:
env: TOXENV=py37 CC=clang
dist: xenial
sudo: true
+ - python: 3.8
+ env: TOXENV=py38 CC=clang
+ dist: xenial
+ sudo: true
- python: pypy
env: TOXENV=pypy CC=clang
- python: 2.7
diff --git a/azure-pipelines.yml b/azure-pipelines.yml
index 498b564..6730219 100644
--- a/azure-pipelines.yml
+++ b/azure-pipelines.yml
@@ -84,6 +84,14 @@ jobs:
TOXENV: py37
containerImage: 'pyca/cryptography-runner-windows:py3-x86_64'
PYTHON_DIR: 'Python37'
+ Python38-x86:
+ TOXENV: py38
+ containerImage: 'pyca/cryptography-runner-windows:py3-x86'
+ PYTHON_DIR: 'Python38'
+ Python38-x86-64:
+ TOXENV: py38
+ containerImage: 'pyca/cryptography-runner-windows:py3-x86_64'
+ PYTHON_DIR: 'Python38'
steps:
- script: "C:/%PYTHON_DIR%/Scripts/tox"
displayName: 'Run tests'
diff --git a/setup.py b/setup.py
index ced8d42..e5ba3ed 100644
--- a/setup.py
+++ b/setup.py
@@ -233,6 +233,7 @@ setup(
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
],
ext_package="bcrypt",
diff --git a/tox.ini b/tox.ini
index cd87450..b97d65b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,6 @@
[tox]
-envlist = py27,pypy,py34,py35,py36,py37,pep8,py3pep8,packaging
+envlist = py27,pypy,py34,py35,py36,py37,py38,pep8,py3pep8,packaging
+isolated_build = True
[testenv]
extras =