summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorSviatoslav Sydorenko <wk.cvs.github@sydorenko.org.ua>2019-05-07 15:08:38 -0400
committerAlex Gaynor <alex.gaynor@gmail.com>2019-05-07 15:08:38 -0400
commitbc8a55e70e179a59fa89fb109353182f8f438e00 (patch)
tree47d527da571f68fc79fdab8f5775eb4f76691694 /pyproject.toml
parent0920783008db2106fece81d79d550563f320de2a (diff)
downloadpy-bcrypt-git-bc8a55e70e179a59fa89fb109353182f8f438e00.tar.gz
Pin the lower bound of PEP517-required setuptools (#171)
* Pin the lower bound of PEP517-required setuptools It fails with Pip's buggy build env isolation combined with the default fallback for the build backend which is ``setuptools.build_meta.__legacy__``. * Point to setuptools PEP 517 backend explicitly
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 33fb811..f821a2e 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,7 +1,10 @@
[build-system]
# Must be kept in sync with `setup_requirements` in `setup.py`
requires = [
- "setuptools",
+ "setuptools>=40.8.0",
"wheel",
"cffi>=1.1; python_implementation != 'PyPy'",
]
+# Point to the setuptools' PEP517 build backend explicitly to
+# disable Pip's fallback guessing
+build-backend = "setuptools.build_meta"