summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2022-02-20 16:12:28 -0500
committerGitHub <noreply@github.com>2022-02-21 05:12:28 +0800
commit742723a99e20412c861794c7a81b55f66637ccd5 (patch)
tree420cf07fc82f541aaaca229beb701adad0469b72 /setup.cfg
parentda826b3fd870b62df369957805568ceeccc88a34 (diff)
downloadpy-bcrypt-git-742723a99e20412c861794c7a81b55f66637ccd5.tar.gz
Move most setup.py configuration into setup.cfg (#293)
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup.cfg b/setup.cfg
index 0c9e0fc..8f664d0 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,2 +1,40 @@
[metadata]
+name = bcrypt
+version = attr: bcrypt.__about__.__version__
+description = attr: bcrypt.__about__.__summary__
+long_description = file: README.rst
+long_description_content_type = text/x-rst
+license = attr: bcrypt.__about__.__license__
license_file = LICENSE
+url = attr: bcrypt.__about__.__uri__
+author = attr: bcrypt.__about__.__author__
+author_email = attr: bcrypt.__about__.__email__
+classifiers =
+ Development Status :: 5 - Production/Stable"
+ License :: OSI Approved :: Apache Software License"
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: Implementation :: PyPy
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3 :: Only
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Programming Language :: Python :: 3.8
+ Programming Language :: Python :: 3.9
+
+[options]
+python_requires = >=3.6
+zip_safe = False
+package_dir =
+ =src
+packages =
+ bcrypt
+ext_package = bcrypt
+# `install_requires` must be kept in sync with `pyproject.toml`
+install_requires =
+ cffi>=1.1
+
+[options.extras_require]
+tests =
+ pytest>=3.2.1,!=3.3.0
+typecheck =
+ mypy