summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-10-30 06:38:47 -0700
committerAlex Gaynor <alex.gaynor@gmail.com>2018-10-30 09:38:47 -0400
commitc3dc912caed2f39b2330a975fd4f217acc45f44a (patch)
tree7a70d097638126c42be581bc0c45fb3f4acb8c48 /setup.py
parent271ac9f2af50859a4f7e4ece622cb8d59710cc8b (diff)
downloadpy-bcrypt-git-c3dc912caed2f39b2330a975fd4f217acc45f44a.tar.gz
Pass python_requires argument to setuptools (#154)
Helps pip decide what version of the library to install. https://packaging.python.org/guides/distributing-packages-using-setuptools/#python-requires > If your project only runs on certain Python versions, setting the > python_requires argument to the appropriate PEP 440 version specifier > string will prevent pip from installing the project on other Python > versions. https://setuptools.readthedocs.io/en/latest/setuptools.html#new-and-changed-setup-keywords > python_requires > > A string corresponding to a version specifier (as defined in PEP 440) > for the Python version, used to specify the Requires-Python defined in > PEP 345.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 398ba7c..ced8d42 100644
--- a/setup.py
+++ b/setup.py
@@ -200,6 +200,7 @@ setup(
author=__about__["__author__"],
author_email=__about__["__email__"],
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
install_requires=[
CFFI_DEPENDENCY,
SIX_DEPENDENCY,