summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorDonald Stufft <donald@stufft.io>2014-12-05 20:54:56 -0500
committerDonald Stufft <donald@stufft.io>2014-12-05 20:54:56 -0500
commit7532ee4eb379078f204460324d7257c1db84c389 (patch)
treefd67b4c9edcb6f49a47b62524504c6796cbc6c4d /tox.ini
parent4c173b52ac277ca7c65f54433b773108c59aab4c (diff)
downloadpy-bcrypt-git-7532ee4eb379078f204460324d7257c1db84c389.tar.gz
Enable flake8 style checks
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini24
1 files changed, 23 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 09b4bc8..6602901 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,pypy,py32,py33,py34
+envlist = py26,py27,pypy,py32,py33,py34,pep8,py3pep8
[testenv]
# If you add a new dep here you probably need to add it in setup.py as well
@@ -8,3 +8,25 @@ deps =
pytest
commands =
py.test --strict {posargs}
+
+[testenv:pep8]
+deps =
+ flake8
+ flake8-import-order
+ pep8-naming
+commands =
+ flake8 .
+
+[testenv:py3pep8]
+basepython = python3.3
+deps =
+ flake8
+ flake8-import-order
+ pep8-naming
+commands =
+ flake8 .
+
+[flake8]
+exclude = .tox,*.egg
+select = E,W,F,N,I
+application-import-names = bcrypt,tests