summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorDonald Stufft <donald@stufft.io>2016-06-30 13:05:21 -0400
committerPaul Kehrer <paul.l.kehrer@gmail.com>2016-06-30 12:05:21 -0500
commitdcbfcccb7eabd30726fc84485bf7c012a4d3966b (patch)
tree1616bd425e56badf20127df0b6db3664e1f29a01 /tox.ini
parentc95966955b60a446e9d23af0b9500fbc5e43c0cc (diff)
downloadpy-bcrypt-git-dcbfcccb7eabd30726fc84485bf7c012a4d3966b.tar.gz
Fix packaging (#87)
* Ensure that all files are packaged or excluded * Add a test to ensure our packaging stays correct
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 10 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index abc6283..264d9aa 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,pypy,py33,py34,py35,pep8,py3pep8
+envlist = py26,py27,pypy,py33,py34,py35,pep8,py3pep8,packaging
[testenv]
# If you add a new dep here you probably need to add it in setup.py as well
@@ -27,6 +27,15 @@ deps =
commands =
flake8 .
+[testenv:packaging]
+deps =
+ check-manifest
+ readme_renderer
+commands =
+ check-manifest
+ python setup.py check --metadata --restructuredtext --strict
+
+
[flake8]
exclude = .tox,*.egg
select = E,W,F,N,I