summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup.cfg b/setup.cfg
index 0c9e0fc..8f664d0 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,2 +1,40 @@
[metadata]
+name = bcrypt
+version = attr: bcrypt.__about__.__version__
+description = attr: bcrypt.__about__.__summary__
+long_description = file: README.rst
+long_description_content_type = text/x-rst
+license = attr: bcrypt.__about__.__license__
license_file = LICENSE
+url = attr: bcrypt.__about__.__uri__
+author = attr: bcrypt.__about__.__author__
+author_email = attr: bcrypt.__about__.__email__
+classifiers =
+ Development Status :: 5 - Production/Stable"
+ License :: OSI Approved :: Apache Software License"
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: Implementation :: PyPy
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3 :: Only
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Programming Language :: Python :: 3.8
+ Programming Language :: Python :: 3.9
+
+[options]
+python_requires = >=3.6
+zip_safe = False
+package_dir =
+ =src
+packages =
+ bcrypt
+ext_package = bcrypt
+# `install_requires` must be kept in sync with `pyproject.toml`
+install_requires =
+ cffi>=1.1
+
+[options.extras_require]
+tests =
+ pytest>=3.2.1,!=3.3.0
+typecheck =
+ mypy