summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 1db9191..7cefac2 100644
--- a/setup.py
+++ b/setup.py
@@ -206,7 +206,7 @@ setup(
license=__about__["__license__"],
author=__about__["__author__"],
author_email=__about__["__email__"],
- python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
+ python_requires=">=3.6",
install_requires=[CFFI_DEPENDENCY, SIX_DEPENDENCY],
extras_require={"tests": ["pytest>=3.2.1,!=3.3.0"]},
tests_require=["pytest>=3.2.1,!=3.3.0"],
@@ -218,10 +218,7 @@ setup(
"License :: OSI Approved :: Apache Software License",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",