summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini24
1 files changed, 23 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 09b4bc8..6602901 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,pypy,py32,py33,py34
+envlist = py26,py27,pypy,py32,py33,py34,pep8,py3pep8
[testenv]
# If you add a new dep here you probably need to add it in setup.py as well
@@ -8,3 +8,25 @@ deps =
pytest
commands =
py.test --strict {posargs}
+
+[testenv:pep8]
+deps =
+ flake8
+ flake8-import-order
+ pep8-naming
+commands =
+ flake8 .
+
+[testenv:py3pep8]
+basepython = python3.3
+deps =
+ flake8
+ flake8-import-order
+ pep8-naming
+commands =
+ flake8 .
+
+[flake8]
+exclude = .tox,*.egg
+select = E,W,F,N,I
+application-import-names = bcrypt,tests