summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordjm <devnull@localhost>2010-06-13 23:18:52 +0000
committerdjm <devnull@localhost>2010-06-13 23:18:52 +0000
commite4249423b1f37a454a374c2aae94ff088026a15e (patch)
tree455f104ca75aacc4775d7954527b2380c7cf0d04
parent6817d1859223686e92ce766ef084b43dcc5a10d4 (diff)
downloadpy-bcrypt-e4249423b1f37a454a374c2aae94ff088026a15e.tar.gz
- (djm) Prefer setuptools for packaging. Based on patch from Niall
O'Higgins.
-rw-r--r--ChangeLog4
-rw-r--r--PKG-INFO2
-rw-r--r--TODO2
-rwxr-xr-xsetup.py13
4 files changed, 14 insertions, 7 deletions
diff --git a/ChangeLog b/ChangeLog
index d9d8de5..9e2b247 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+20100614
+ - (djm) Prefer setuptools for packaging. Based on patch from Niall
+ O'Higgins.
+
20091001
- (djm) Allow Python threads to run during (potentially lengthy) bcrypt
operation. Patch from vijay AT meebo-inc.com
diff --git a/PKG-INFO b/PKG-INFO
index 5f17671..80ff3e7 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.0
Name: py-bcrypt
-Version: 0.1
+Version: 0.2
Summary: Blowfish password hashing library
Home-page: http://www.mindrot.org/py-bcrypt.html
Author: Damien Miller
diff --git a/TODO b/TODO
index a8d8a34..37d3db8 100644
--- a/TODO
+++ b/TODO
@@ -1,3 +1,3 @@
-Nothing yet
+Python 3 support
$Id$
diff --git a/setup.py b/setup.py
index 3f5325b..c2cd789 100755
--- a/setup.py
+++ b/setup.py
@@ -17,15 +17,18 @@
# $Id$
import sys
-from distutils.core import setup, Extension
-
-VERSION = "0.1"
-
+try:
+ from setuptools import setup, Extension
+except ImportError:
+ from distutils.core import setup, Extension
+
+VERSION = "0.2"
+
if __name__ == '__main__':
bcrypt = Extension('bcrypt._bcrypt',
sources = ['bcrypt/bcrypt_python.c', 'bcrypt/blowfish.c',
'bcrypt/bcrypt.c'])
- setup( name = "bcrypt",
+ setup( name = "py-bcrypt",
version = VERSION,
author = "Damien Miller",
author_email = "djm@mindrot.org",