summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2012-07-23 16:33:08 +0000
committerelie <elie>2012-07-23 16:33:08 +0000
commit0a372c035785768765512a7cdcdc99e1a300ce2f (patch)
tree4bc885d800d494f2e352423267269847f6b4985f /setup.py
parent43a18b66e2126cf1b2bf7987a1af12d1e163fa7a (diff)
downloadpyasn1-git-0a372c035785768765512a7cdcdc99e1a300ce2f.tar.gz
mention the distribute package
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 19 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 141e8cb..736d0fa 100644
--- a/setup.py
+++ b/setup.py
@@ -23,13 +23,28 @@ Topic :: Security :: Cryptography
Topic :: Software Development :: Libraries :: Python Modules
"""
+def howto_install_distribute():
+ print("""
+ Error: You need the distribute Python package!
+
+ It's very easy to install it, just type (as root on Linux):
+
+ wget http://python-distribute.org/distribute_setup.py
+ python distribute_setup.py
+
+ Then you could make eggs from this package.
+""")
+
def howto_install_setuptools():
print("""
Error: You need setuptools Python package!
It's very easy to install it, just type (as root on Linux):
+
wget http://peak.telecommunity.com/dist/ez_setup.py
python ez_setup.py
+
+ Then you could make eggs from this package.
""")
try:
@@ -41,7 +56,10 @@ except ImportError:
import sys
for arg in sys.argv:
if arg.find('egg') != -1:
- howto_install_setuptools()
+ if sys.version_info[0] > 2:
+ howto_install_distribute()
+ else:
+ howto_install_setuptools()
sys.exit(1)
from distutils.core import setup
params = {}