summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2010-12-12 17:36:27 +0000
committerelie <elie>2010-12-12 17:36:27 +0000
commit0e5bcb2bcf5d78bfd785172e07ca8ba6bca7caa3 (patch)
tree82e775791f91ea434fe12dbffb2613cd464ccf75 /setup.py
parent41bbb1a64b8d22168287ccb7b51af107a2e44c23 (diff)
downloadpyasn1-git-0e5bcb2bcf5d78bfd785172e07ca8ba6bca7caa3.tar.gz
* 0.0.12a
* pass zip_safe flag
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py35
1 files changed, 21 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 643e660..8c568cd 100644
--- a/setup.py
+++ b/setup.py
@@ -12,24 +12,31 @@ It's very easy to install it, just type (as root on Linux):
try:
from setuptools import setup
+ params = {
+ 'zip_safe': True
+ }
except ImportError:
for arg in sys.argv:
if string.find(arg, 'egg') != -1:
howto_install_setuptools()
sys.exit(1)
from distutils.core import setup
+ params = {}
-setup(name = 'pyasn1',
- version = '0.0.11a',
- description = 'ASN.1 types and codecs',
- author = 'Ilya Etingof',
- author_email = 'ilya@glas.net',
- url = 'http://sourceforge.net/projects/pyasn1/',
- license = 'BSD',
- packages = [ 'pyasn1',
- 'pyasn1.type',
- 'pyasn1.codec',
- 'pyasn1.codec.ber',
- 'pyasn1.codec.cer',
- 'pyasn1.codec.der' ]
- )
+params.update( {
+ 'name': 'pyasn1',
+ 'version': '0.0.12a',
+ 'description': 'ASN.1 types and codecs',
+ 'author': 'Ilya Etingof',
+ 'author_email': 'ilya@glas.net',
+ 'url': 'http://sourceforge.net/projects/pyasn1/',
+ 'license': 'BSD',
+ 'packages': [ 'pyasn1',
+ 'pyasn1.type',
+ 'pyasn1.codec',
+ 'pyasn1.codec.ber',
+ 'pyasn1.codec.cer',
+ 'pyasn1.codec.der' ]
+ } )
+
+apply(setup, (), params)