summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2019-11-16 10:19:07 -0800
committerIlya Etingof <etingof@gmail.com>2019-11-16 19:19:07 +0100
commita7d2ac036866e5f437bd6f9a9f01723f601b4073 (patch)
tree543d918472952d4d7b41ff9ea3ff56fc21b38448 /setup.py
parente51d6f520bdd57748f70b8defc2bda1ddea9856b (diff)
downloadpyasn1-git-a7d2ac036866e5f437bd6f9a9f01723f601b4073.tar.gz
Drop support for EOL Pythons (#131)
Python 2.4, 2.5, 2.6, 3.2 and 3.3 are end of life. They are no longer receiving bug fixes, including for security issues. These Pythons went EOL on: Python 2.6: 2013-10-29 Python 3.2: 2016-02-20 Python 3.3: 2017-09-29 For additional details on supported Python versions, see: https://devguide.python.org/#status-of-python-branches Removing support for EOL Pythons will reduce testing and maintenance resources. Using pypinfo, here are the download statistics of the project for the last 30 days, showing limited downloads from EOL Pythons: | python_version | percent | download_count | | -------------- | ------: | -------------: | | 2.7 | 90.33% | 7,975,885 | | 3.6 | 4.95% | 437,261 | | 3.5 | 2.99% | 263,637 | | 3.4 | 1.02% | 89,723 | | 2.6 | 0.69% | 60,511 | | 3.7 | 0.02% | 2,024 | | 3.3 | 0.00% | 441 | | 3.2 | 0.00% | 38 | | 3.8 | 0.00% | 9 | | None | 0.00% | 2 | By removing support for older Pythons, can remove or update the following workarounds and code: * Built-in function bin() is always available. * Built-in function callable() is always available. * Built-in function all() is always available. * The collections.OrderedDict class is always available. * The datetime.strptime() method is always available. * The platform module is always available. * The string.partition() method is always available. * The NullHandler class is always available. * The method .__trunc__() is always available. * Can use set literals. * Updated unittest is always available. The unittest2 module is unnecessary. Users on older versions of Python can continue to download, install, and use older versions of the library that continue to have support for older Pythons.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 5 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index fa0a876..1992835 100644
--- a/setup.py
+++ b/setup.py
@@ -7,6 +7,7 @@
#
import os
import sys
+import unittest
classifiers = """\
Development Status :: 5 - Production/Stable
@@ -20,13 +21,8 @@ License :: OSI Approved :: BSD License
Natural Language :: English
Operating System :: OS Independent
Programming Language :: Python :: 2
-Programming Language :: Python :: 2.4
-Programming Language :: Python :: 2.5
-Programming Language :: Python :: 2.6
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
-Programming Language :: Python :: 3.2
-Programming Language :: Python :: 3.3
Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
@@ -49,8 +45,8 @@ def howto_install_setuptools():
""")
-if sys.version_info[:2] < (2, 4):
- print("ERROR: this package requires Python 2.4 or later!")
+if sys.version_info[:2] < (2, 7):
+ print("ERROR: this package requires Python 2.7 or later!")
sys.exit(1)
try:
@@ -88,13 +84,8 @@ params.update({
'pyasn1.codec.ber',
'pyasn1.codec.cer',
'pyasn1.codec.der',
- 'pyasn1.codec.native']})
-
-# handle unittest discovery feature
-try:
- import unittest2 as unittest
-except ImportError:
- import unittest
+ 'pyasn1.codec.native'],
+ 'python_requires': '>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*'})
class PyTest(Command):