summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2013-09-21 09:43:29 +0000
committerelie <elie>2013-09-21 09:43:29 +0000
commiteaa403616e3a48e590c6feb3f61877e6d87e4653 (patch)
tree7bd010d736ba680c65b5579386acb2aac94fb519 /setup.py
parentf842772eeb636a41cd051c138ef015793a0b9dfa (diff)
downloadpyasn1-git-eaa403616e3a48e590c6feb3f61877e6d87e4653.tar.gz
distribute is gone
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 3 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index 194f0c8..2817cbc 100644
--- a/setup.py
+++ b/setup.py
@@ -26,25 +26,13 @@ Topic :: Security :: Cryptography
Topic :: Software Development :: Libraries :: Python Modules
"""
-def howto_install_distribute():
- print("""
- Error: You need the distribute Python package!
-
- It's very easy to install it, just type (as root on Linux):
-
- wget http://python-distribute.org/distribute_setup.py
- python distribute_setup.py
-
- Then you could make eggs from this package.
-""")
-
def howto_install_setuptools():
print("""
Error: You need setuptools Python package!
It's very easy to install it, just type (as root on Linux):
- wget http://peak.telecommunity.com/dist/ez_setup.py
+ wget https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py
python ez_setup.py
Then you could make eggs from this package.
@@ -57,11 +45,8 @@ try:
}
except ImportError:
for arg in sys.argv:
- if arg.find('egg') != -1:
- if sys.version_info[0] > 2:
- howto_install_distribute()
- else:
- howto_install_setuptools()
+ if 'egg' in arg:
+ howto_install_setuptools()
sys.exit(1)
from distutils.core import setup, Command
params = {}