summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2011-10-04 11:24:24 +0000
committerelie <elie>2011-10-04 11:24:24 +0000
commitec28f2de04d678b5791b0c6fe369adaf2b256a53 (patch)
tree9d205dedc2892fa13105b36933da1e0d6cecd6cb /setup.py
parent0b7c3c3031a3c7a50e819e32e224027fbafadcad (diff)
downloadpyasn1-git-ec28f2de04d678b5791b0c6fe369adaf2b256a53.tar.gz
minor py3k compatibility fixes
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 6 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 8c436e5..d0a9b53 100644
--- a/setup.py
+++ b/setup.py
@@ -2,12 +2,13 @@
import sys
def howto_install_setuptools():
- print """Error: You need setuptools Python package!
+ print("""
+ Error: You need setuptools Python package!
-It's very easy to install it, just type (as root on Linux):
+ It's very easy to install it, just type (as root on Linux):
wget http://peak.telecommunity.com/dist/ez_setup.py
python ez_setup.py
-"""
+""")
try:
from setuptools import setup
@@ -32,10 +33,11 @@ params.update( {
'license': 'BSD',
'packages': [ 'pyasn1',
'pyasn1.type',
+ 'pyasn1.compat',
'pyasn1.codec',
'pyasn1.codec.ber',
'pyasn1.codec.cer',
'pyasn1.codec.der' ]
} )
-apply(setup, (), params)
+setup(**params)