summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml10
-rw-r--r--README.md35
2 files changed, 30 insertions, 15 deletions
diff --git a/.travis.yml b/.travis.yml
index fec157a..1944641 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -10,5 +10,11 @@ python:
- "nightly"
- "pypy"
- "pypy3"
-install: python setup.py install
-script: python test/suite.py
+before_install:
+ - pip install codecov
+install:
+ - python setup.py install
+script:
+ - python test/suite.py
+after_success:
+ - codecov
diff --git a/README.md b/README.md
index 9d5771c..c69b3e8 100644
--- a/README.md
+++ b/README.md
@@ -1,12 +1,18 @@
-ASN.1 library for Python ![build-status](https://travis-ci.org/etingof/pyasn1.svg?branch=master)
+ASN.1 library for Python
------------------------
-
-
-This is a free and open source implementation of ASN.1 types and codecs as a Python
-package. It has been first written to support particular protocol (SNMP)
-but then generalized to be suitable for a wide range of protocols
-based on ASN.1 specification.
+[![Can I Use Python 3?](https://caniusepython3.com/project/pyasn1.svg)](https://caniusepython3.com/project/pyasn1)
+[![GitHub license](https://img.shields.io/badge/license-BSD-blue.svg)](https://raw.githubusercontent.com/etingof/pyasn1/master/LICENSE.txt)
+[![Downloads](https://img.shields.io/pypi/dm/pyasn1.svg)](https://pypi.python.org/pypi/pyasn1)
+[![Build status](https://travis-ci.org/etingof/pyasn1.svg?branch=master)](https://secure.travis-ci.org/etingof/pyasn1)
+[![Coverage Status](https://img.shields.io/codecov/c/github/etingof/pyasn1.svg](https://codecov.io/github/etingof/pyasn1/coverage.svg?branch=master)
+[![Coverage Status](https://img.shields.io/codecov/etingof/pyasn1.svg)](https://codecov.io/github/etingof/pyasn1/coverage.svg?branch=master)
+
+This is a free and open source implementation of ASN.1 types and codecs
+as a Python package. It has been first written to support particular
+protocol (SNMP) but then generalized to be suitable for a wide range
+of protocols based on
+[ASN.1 specification](https://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-X.208-198811-W!!PDF-E&type=items).
Features
--------
@@ -35,8 +41,10 @@ Download pyasn1 from [PyPI](https://pypi.python.org/pypi/pyasn1) or just run:
Documentation
-------------
-Information on pyasn1 APIs can be found in the [documentation](http://pyasn1.sourceforge.net),
-working examples are in the pyasn1-modeules [repo](https://github.com/etingof/pyasn1-modules).
+Information on pyasn1 APIs can be found in the
+[documentation](http://pyasn1.sourceforge.net),
+working examples are in the pyasn1-modules
+[repo](https://github.com/etingof/pyasn1-modules).
Download
--------
@@ -49,7 +57,8 @@ Feedback
--------
If something does not work as expected, try browsing pyasn1
-[mailing list archives](https://sourceforge.net/p/pyasn1/mailman/pyasn1-users/) or post
-your question [to Stack Overflow](http://stackoverflow.com/questions/ask).
-
-Copyright (c) 2005-2016, [Ilya Etingof](http://ilya@glas.net). All rights reserved.
+[mailing list archives](https://sourceforge.net/p/pyasn1/mailman/pyasn1-users/)
+or post your question
+[to Stack Overflow](http://stackoverflow.com/questions/ask).
+Copyright (c) 2005-2016, [Ilya Etingof](http://ilya@glas.net).
+All rights reserved.