summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorelie <elie>2013-09-21 09:43:29 +0000
committerelie <elie>2013-09-21 09:43:29 +0000
commit8342112691441d271465354b1b5c7dc930435f97 (patch)
treed6a40467d5a45702a2a76ec18ae8c204db424e8d
parentc3c3e08cfb4cf12bcceb2f12d7eb492a2777b7ed (diff)
downloadpyasn1-8342112691441d271465354b1b5c7dc930435f97.tar.gz
distribute is gone
-rw-r--r--CHANGES1
-rw-r--r--setup.py21
2 files changed, 4 insertions, 18 deletions
diff --git a/CHANGES b/CHANGES
index 5e419ec..43374eb 100644
--- a/CHANGES
+++ b/CHANGES
@@ -7,6 +7,7 @@ Revision 0.1.8
a MT execution environment.
- Missing T61String,ISO646String character types and ObjectDescriptor useful
type added.
+- Distribute is gone, switched to setuptools completely.
- Fix to NamedType.__repr__() to work properly.
- Float typed mantissa initializer to REAL type for base 2 added.
- Encoding bases 8 and 16 support for REAL type binary encoder added.
diff --git a/setup.py b/setup.py
index 194f0c8..2817cbc 100644
--- a/setup.py
+++ b/setup.py
@@ -26,25 +26,13 @@ Topic :: Security :: Cryptography
Topic :: Software Development :: Libraries :: Python Modules
"""
-def howto_install_distribute():
- print("""
- Error: You need the distribute Python package!
-
- It's very easy to install it, just type (as root on Linux):
-
- wget http://python-distribute.org/distribute_setup.py
- python distribute_setup.py
-
- Then you could make eggs from this package.
-""")
-
def howto_install_setuptools():
print("""
Error: You need setuptools Python package!
It's very easy to install it, just type (as root on Linux):
- wget http://peak.telecommunity.com/dist/ez_setup.py
+ wget https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py
python ez_setup.py
Then you could make eggs from this package.
@@ -57,11 +45,8 @@ try:
}
except ImportError:
for arg in sys.argv:
- if arg.find('egg') != -1:
- if sys.version_info[0] > 2:
- howto_install_distribute()
- else:
- howto_install_setuptools()
+ if 'egg' in arg:
+ howto_install_setuptools()
sys.exit(1)
from distutils.core import setup, Command
params = {}