summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorelie <elie>2015-09-28 12:23:06 +0000
committerelie <elie>2015-09-28 12:23:06 +0000
commitc4c98c3d9a05eb3fb0a63bd5098a03081056a38c (patch)
tree63a28120a509821a9d3850cee8b9c7b02853ce5b
parentcf978bb52fd25b940e9a0694798425ad0455e01f (diff)
downloadpyasn1-c4c98c3d9a05eb3fb0a63bd5098a03081056a38c.tar.gz
note asn1late
-rw-r--r--README.txt70
1 files changed, 70 insertions, 0 deletions
diff --git a/README.txt b/README.txt
new file mode 100644
index 0000000..f03f51f
--- /dev/null
+++ b/README.txt
@@ -0,0 +1,70 @@
+
+ASN.1 library for Python
+------------------------
+
+This is an implementation of ASN.1 types and codecs in Python programming
+language. It has been first written to support particular protocol (SNMP)
+but then generalized to be suitable for a wide range of protocols
+based on ASN.1 specification.
+
+FEATURES
+--------
+
+* Generic implementation of ASN.1 types (X.208)
+* Fully standard compliant BER/CER/DER codecs
+* 100% Python, works with Python 2.4 up to Python 3.5
+* MT-safe
+
+MISFEATURES
+-----------
+
+* No ASN.1 compiler shipped with pyasn1, so by-hand ASN.1 spec compilation
+ into Python code would be needed. But there is a project, called Asn1ate,
+ that compiles ASN.1 documents into pyasn1 code.
+ More info: https://github.com/kimgr/asn1ate
+* Codecs are not restartable
+
+INSTALLATION
+------------
+
+The pyasn1 package uses setuptools/distutils for installation. Thus do
+either:
+
+$ easy_install pyasn1
+
+or
+
+$ tar zxf pyasn1-0.1.9.tar.gz
+$ cd pyasn1-0.1.9
+$ python setup.py install
+$ python setup.py test # run unit tests (optional)
+
+OPERATION
+---------
+
+Perhaps a typical use would involve [by-hand] compilation of your ASN.1
+specification into pyasn1-backed Python code at your application.
+
+For more information on pyasn1 APIs, please, refer to the
+doc/pyasn1-tutorial.html file in the distribution.
+
+Also refer to example modules. Take a look at pyasn1-modules package -- maybe
+it already holds something useful to you.
+
+AVAILABILITY
+------------
+
+The pyasn1 package is distributed under terms and conditions of BSD-style
+license. See LICENSE file in the distribution. Source code is freely
+available from:
+
+http://pyasn1.sf.net
+
+
+FEEDBACK
+--------
+
+Please, send your comments and fixes to mailing lists at project web site.
+
+=-=-=
+mailto: ilya@glas.net