summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST57
-rw-r--r--MANIFEST.in4
-rw-r--r--setup.py19
3 files changed, 14 insertions, 66 deletions
diff --git a/MANIFEST b/MANIFEST
deleted file mode 100644
index 475d615..0000000
--- a/MANIFEST
+++ /dev/null
@@ -1,57 +0,0 @@
-CHANGES
-MANIFEST
-README
-THANKS
-LICENSE
-doc/notes.html
-pyasn1/error.py
-pyasn1/codec/ber/decoder.py
-pyasn1/codec/ber/encoder.py
-pyasn1/codec/ber/__init__.py
-pyasn1/codec/ber/eoo.py
-pyasn1/codec/cer/__init__.py
-pyasn1/codec/cer/encoder.py
-pyasn1/codec/cer/decoder.py
-pyasn1/codec/der/__init__.py
-pyasn1/codec/der/decoder.py
-pyasn1/codec/der/encoder.py
-pyasn1/codec/__init__.py
-pyasn1/type/base.py
-pyasn1/type/tag.py
-pyasn1/type/univ.py
-pyasn1/type/__init__.py
-pyasn1/type/namedtype.py
-pyasn1/type/namedval.py
-pyasn1/type/error.py
-pyasn1/type/constraint.py
-pyasn1/type/char.py
-pyasn1/type/useful.py
-pyasn1/__init__.py
-test/__init__.py
-test/suite.py
-test/codec/ber/__init__.py
-test/codec/ber/encoder.py
-test/codec/ber/suite.py
-test/codec/ber/decoder.py
-test/codec/__init__.py
-test/codec/cer/__init__.py
-test/codec/cer/encoder.py
-test/codec/cer/suite.py
-test/codec/cer/decoder.py
-test/codec/der/__init__.py
-test/codec/der/encoder.py
-test/codec/der/suite.py
-test/codec/der/decoder.py
-test/type/univ.py
-test/type/__init__.py
-test/type/suite.py
-test/type/tag.py
-test/type/constraint.py
-test/type/namedtype.py
-examples/x509.py
-examples/ldap.py
-examples/ocsp.py
-examples/snmp.py
-examples/sshkey.py
-TODO
-setup.py
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..94a21cc
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1,4 @@
+include CHANGES README LICENSE THANKS TODO
+recursive-include examples *.py
+recursive-include test *.py
+recursive-include docs *.txt *.html
diff --git a/setup.py b/setup.py
index cc86ea5..267ff6e 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
#!/usr/bin/env python
import sys
+import string
def howto_install_setuptools():
print """Error: You need setuptools Python package!
@@ -13,22 +14,22 @@ try:
from setuptools import setup
except ImportError:
for arg in sys.argv:
- if "egg" in arg:
+ if string.find(arg, 'egg') == -1:
howto_install_setuptools()
sys.exit(1)
from distutils.core import setup
-setup(name="pyasn1",
- version="0.0.11a",
- description="ASN.1 library for Python",
- author="Ilya Etingof",
- author_email="ilya@glas.net ",
- url="http://sourceforge.net/projects/pyasn1/",
+setup(name = 'pyasn1',
+ version = '0.0.11a',
+ description = 'ASN.1 types and codecs',
+ author = 'Ilya Etingof',
+ author_email = 'ilya@glas.net',
+ url = 'http://sourceforge.net/projects/pyasn1/',
+ license = 'BSD',
packages = [ 'pyasn1',
'pyasn1.type',
'pyasn1.codec',
'pyasn1.codec.ber',
'pyasn1.codec.cer',
- 'pyasn1.codec.der' ],
- license="BSD"
+ 'pyasn1.codec.der' ]
)