summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py19
1 files changed, 18 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 36a9800..19eb815 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,22 @@
#!/usr/bin/env python
-from distutils.core import setup
+import sys
+
+def howto_install_setuptools():
+ print """Error: You need setuptools Python package!
+
+It's very easy to install it, just type (as root on Linux):
+ wget http://peak.telecommunity.com/dist/ez_setup.py
+ python ez_setup.py
+"""
+
+try:
+ from setuptools import setup
+except ImportError:
+ for arg in sys.argv:
+ if "egg" in arg:
+ howto_install_setuptools()
+ sys.exit(1)
+ from distutils.core import setup
setup(name="pyasn1",
version="0.0.5a",