summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2015-07-28 21:32:41 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2015-07-28 21:32:41 +0000
commite5c260eee42146dc819117c87664a2337313381d (patch)
tree9ab2fe3f1ef450cfc4619356ce4915cdfb489973
parent53f8fc4858115dc6a2985a9a7e85754ee94a1a5a (diff)
downloadpycadf-stable/juno.tar.gz
Updated from global requirementsjuno-eolstable/juno
Change-Id: I5210b3cae3ceac6bc63fba0f92f814afed4a66f6
-rw-r--r--requirements.txt14
-rw-r--r--setup.py1
-rw-r--r--test-requirements.txt26
3 files changed, 20 insertions, 21 deletions
diff --git a/requirements.txt b/requirements.txt
index dec65e2..d21de79 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,11 +1,11 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
-Babel>=1.3,<=1.3
-iso8601>=0.1.9,<=0.1.10
-netaddr>=0.7.12,<=0.7.13
-oslo.config>=1.4.0,<=1.6.0 # Apache-2.0
-posix_ipc<=0.9.9
+Babel<=1.3,>=1.3
+iso8601<=0.1.10,>=0.1.9
+netaddr<=0.7.13,>=0.7.12
+oslo.config<=1.6.0,>=1.4.0 # Apache-2.0
+posix-ipc<=0.9.9
pytz
-six>=1.7.0,<=1.9.0
-WebOb>=1.2.3,<=1.3.1
+six<=1.9.0,>=1.7.0
+WebOb<=1.3.1,>=1.2.3
diff --git a/setup.py b/setup.py
index 7363757..056c16c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,3 @@
-#!/usr/bin/env python
# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");
diff --git a/test-requirements.txt b/test-requirements.txt
index bc33639..e0673b7 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -2,20 +2,20 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
# Hacking already pins down pep8, pyflakes and flake8
-hacking>=0.9.2,<0.10
+hacking<0.10,>=0.9.2
-coverage>=3.6,<=3.7.1
+coverage<=3.7.1,>=3.6
discover<=0.4.0
-fixtures>=0.3.14,<=1.0.0
-mock>=1.0,<=1.0.1
-mox>=0.5.3,<=0.5.3
-mox3>=0.7.0,<=0.7.0
-python-subunit>=0.0.18,<=1.0.0
-testrepository>=0.0.18,<=0.0.20
-testscenarios>=0.4,<=0.4
-testtools>=0.9.34,!=1.4.0,<=1.5.0
-oslo.messaging>=1.4.0,<1.5.0
+fixtures<=1.0.0,>=0.3.14
+mock<=1.0.1,>=1.0
+mox<=0.5.3,>=0.5.3
+mox3<=0.7.0,>=0.7.0
+python-subunit<=1.0.0,>=0.0.18
+testrepository<=0.0.20,>=0.0.18
+testscenarios<=0.4,>=0.4
+testtools!=1.4.0,<=1.5.0,>=0.9.34
+oslo.messaging<1.5.0,>=1.4.0
# this is required for the docs build jobs
-oslosphinx>=2.2.0,<2.5.0 # Apache-2.0
-sphinx>=1.1.2,!=1.2.0,<1.3
+oslosphinx<2.5.0,>=2.2.0 # Apache-2.0
+sphinx!=1.2.0,<1.3,>=1.1.2