summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Hellmann <doug@doughellmann.com>2018-06-06 15:27:01 -0400
committerDoug Hellmann <doug@doughellmann.com>2018-06-06 15:27:01 -0400
commit2c275b08c5edfd226b79a2b4427245fafac4bb50 (patch)
treee3c9a9a7b3261d4870adb05d57e56d6f9997609f
parentf12219db85ed632a8b852f16637e951456155151 (diff)
downloadpycadf-2c275b08c5edfd226b79a2b4427245fafac4bb50.tar.gz
fix tox python3 overrides
We want to default to running all tox environments under python 3, so set the basepython value in each environment. We do not want to specify a minor version number, because we do not want to have to update the file every time we upgrade python. We do not want to set the override once in testenv, because that breaks the more specific versions used in default environments like py35 and py36. Change-Id: I370e66f1a4f4a0af629afa109d51d095a4700327 Signed-off-by: Doug Hellmann <doug@doughellmann.com>
-rw-r--r--tox.ini5
1 files changed, 5 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index 7423a30..a0debd0 100644
--- a/tox.ini
+++ b/tox.ini
@@ -11,18 +11,23 @@ deps =
commands = python setup.py testr --slowest --testr-args='{posargs}'
[testenv:pep8]
+basepython = python3
commands = flake8
[testenv:docs]
+basepython = python3
commands = python setup.py build_sphinx
[testenv:cover]
+basepython = python3
commands = python setup.py testr --coverage
[testenv:venv]
+basepython = python3
commands = {posargs}
[testenv:debug]
+basepython = python3
commands = oslo_debug_helper {posargs}
[flake8]