summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVu Cong Tuan <tuanvc@vn.fujitsu.com>2018-07-10 14:25:26 +0700
committerVu Cong Tuan <tuanvc@vn.fujitsu.com>2018-07-24 10:38:07 +0700
commit833ba0f5b87343b196f1287d607a9de159834a41 (patch)
treea3b55ccfafd24a3359ebef1cc4d26aeae30a77fb
parent7df2d5978005c1a4af33067e77ecd945b38ab13a (diff)
downloadpycadf-833ba0f5b87343b196f1287d607a9de159834a41.tar.gz
Switch to stestr
According to Openstack summit session [1], stestr is maintained project to which all Openstack projects should migrate. Let's switch to stestr as other projects have already moved to it. [1] https://etherpad.openstack.org/p/YVR-python-pti Change-Id: Ib4c7bb59c92946c3e8b257cbf1ce2f44cb1c40ed
-rw-r--r--.gitignore2
-rw-r--r--.stestr.conf3
-rw-r--r--.testr.conf4
-rw-r--r--lower-constraints.txt2
-rw-r--r--test-requirements.txt2
-rw-r--r--tox.ini10
6 files changed, 14 insertions, 9 deletions
diff --git a/.gitignore b/.gitignore
index c0232de..2d8df88 100644
--- a/.gitignore
+++ b/.gitignore
@@ -11,6 +11,6 @@ build/
doc/build/
doc/source/api
dist/
-.testrepository/
+.stestr/
.project
.pydevproject
diff --git a/.stestr.conf b/.stestr.conf
new file mode 100644
index 0000000..b62a6dd
--- /dev/null
+++ b/.stestr.conf
@@ -0,0 +1,3 @@
+[DEFAULT]
+test_path=./pycadf/tests
+top_dir=./
diff --git a/.testr.conf b/.testr.conf
deleted file mode 100644
index 1641f86..0000000
--- a/.testr.conf
+++ /dev/null
@@ -1,4 +0,0 @@
-[DEFAULT]
-test_command=OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_TEST_TIMEOUT=60 ${PYTHON:-python} -m subunit.run discover -t ./ . $LISTOPT $IDOPTION
-test_id_option=--load-list $IDFILE
-test_list_option=--list
diff --git a/lower-constraints.txt b/lower-constraints.txt
index 1117cfa..4c4af0d 100644
--- a/lower-constraints.txt
+++ b/lower-constraints.txt
@@ -48,7 +48,7 @@ snowballstemmer==1.2.1
Sphinx==1.6.2
sphinxcontrib-websupport==1.0.1
stevedore==1.20.0
-testrepository==0.0.18
+stestr==2.0.0
testtools==2.2.0
traceback2==1.4.0
unittest2==1.1.0
diff --git a/test-requirements.txt b/test-requirements.txt
index c3711fc..2aeda8a 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -9,7 +9,7 @@ coverage!=4.4,>=4.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
python-subunit>=1.0.0 # Apache-2.0/BSD
mock>=2.0.0 # BSD
-testrepository>=0.0.18 # Apache-2.0/BSD
+stestr>=2.0.0 # Apache-2.0
testtools>=2.2.0 # MIT
# this is required for the docs build jobs
diff --git a/tox.ini b/tox.ini
index a0debd0..72e6d5b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -8,7 +8,7 @@ deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt}
-r{toxinidir}/test-requirements.txt
-r{toxinidir}/requirements.txt
-commands = python setup.py testr --slowest --testr-args='{posargs}'
+commands = stestr run --slowest {posargs}
[testenv:pep8]
basepython = python3
@@ -20,7 +20,13 @@ commands = python setup.py build_sphinx
[testenv:cover]
basepython = python3
-commands = python setup.py testr --coverage
+setenv =
+ PYTHON=coverage run --source $project --parallel-mode
+commands =
+ stestr run '{posargs}'
+ coverage combine
+ coverage html -d cover
+ coverage xml -o cover/coverage.xml
[testenv:venv]
basepython = python3