summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2018-09-29 19:07:06 +0200
committerAndreas Jaeger <aj@suse.com>2018-09-30 11:29:36 +0200
commite00691f33b970929a04b2072ba26a112f4c6d619 (patch)
tree47d0d3173693653402c765a0f609d7666fac6854
parent1983ea48a6f5b180e244ca8d40408de173d082f1 (diff)
downloadpycadf-e00691f33b970929a04b2072ba26a112f4c6d619.tar.gz
Use templates for cover and lower-constraints
Small cleanups: * Use openstack-tox-cover template, this runs the cover job in the check queue only. Remove individual cover jobs. * Use openstack-lower-constraints-jobs template, remove individual jobs. * Sort list of templates Fix cover job, $project is not expanded in tox.ini and thus the job fails. Use "pycadf" instead. Change-Id: I72da23a0d6c6b3cc87e66d94c419668fce66e704
-rw-r--r--.zuul.yaml17
-rw-r--r--tox.ini2
2 files changed, 6 insertions, 13 deletions
diff --git a/.zuul.yaml b/.zuul.yaml
index b92bf58..79f90b2 100644
--- a/.zuul.yaml
+++ b/.zuul.yaml
@@ -1,18 +1,11 @@
- project:
templates:
+ - check-requirements
+ - lib-forward-testing
+ - lib-forward-testing-python3
+ - openstack-cover-jobs
+ - openstack-lower-constraints-jobs
- openstack-python-jobs
- openstack-python35-jobs
- openstack-python36-jobs
- publish-openstack-docs-pti
- - check-requirements
- - lib-forward-testing
- - lib-forward-testing-python3
- check:
- jobs:
- - openstack-tox-lower-constraints
- gate:
- jobs:
- - openstack-tox-lower-constraints
- post:
- jobs:
- - openstack-tox-cover
diff --git a/tox.ini b/tox.ini
index 72e6d5b..0ecbf53 100644
--- a/tox.ini
+++ b/tox.ini
@@ -21,7 +21,7 @@ commands = python setup.py build_sphinx
[testenv:cover]
basepython = python3
setenv =
- PYTHON=coverage run --source $project --parallel-mode
+ PYTHON=coverage run --source pycadf --parallel-mode
commands =
stestr run '{posargs}'
coverage combine