summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:46:06 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:46:06 +0000
commit2f6fd834b3339096dc2f54b34f2c6667e5d71182 (patch)
tree33b1354622051c358962238829e6f28978702888 /setup.py
parent3e4f5939848e1da99c0291abfb1d83b45abc9aab (diff)
downloadpycadf-2f6fd834b3339096dc2f54b34f2c6667e5d71182.tar.gz
Updated from global requirements
Change-Id: Ib667b02069ba68b4e33eae844caae6d33ba368c3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..7363757 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)