summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorGordon Chung <chungg@ca.ibm.com>2014-01-06 14:52:17 -0500
committerGordon Chung <chungg@ca.ibm.com>2014-03-17 00:28:45 -0400
commit1d5428afa7c4442762737fdca8bad3d533f5e275 (patch)
treeda9589d3892e91dfcfb1920d62757a44cafd78db /tox.ini
parent99dd8b4badcca4da0701fc250b9d3684f8d1ac38 (diff)
downloadpycadf-1d5428afa7c4442762737fdca8bad3d533f5e275.tar.gz
pycadf documentation
add basic documentation on CADF spec. Closes-Bug: #1279951 Change-Id: Ie1703d9b5109d8275377857e5362e3b09385f647 Implements: blueprint document-pycadf
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini5
1 files changed, 5 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index f4a87a2..1f88502 100644
--- a/tox.ini
+++ b/tox.ini
@@ -14,6 +14,11 @@ commands = python setup.py testr --slowest --testr-args='{posargs}'
[testenv:pep8]
commands = flake8
+[testenv:docs]
+deps = -r{toxinidir}/requirements.txt
+ -r{toxinidir}/test-requirements.txt
+commands = python setup.py build_sphinx
+
[testenv:cover]
setenv = VIRTUAL_ENV={envdir}
commands = python setup.py testr --coverage