summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorGordon Chung <chungg@ca.ibm.com>2013-09-17 19:25:16 -0400
committerGordon Chung <chungg@ca.ibm.com>2013-09-17 19:25:16 -0400
commit4f812e032515f5d17471e32892edbeb82024098b (patch)
tree98caa584284f854ee1a14aac1977d68ebcfa4a5f /tox.ini
parent20e65dda8232bd30dc585d2184ed307474b4bcb6 (diff)
downloadpycadf-4f812e032515f5d17471e32892edbeb82024098b.tar.gz
update tox to 1.6
ceilometer uses 1.6, let's utilise it as well to avoid any incompatibility when manually running tests. Change-Id: I9a3323310020381ceeebe7aa86219eff32b92ec1 Fixes: Bug#1226853
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini5
1 files changed, 4 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index ab5e71b..fba98d9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,11 +1,14 @@
[tox]
-distribute = False
+minversion = 1.6
+skipsdist = True
envlist = py26,py27,py33,pep8
[testenv]
setenv = VIRTUAL_ENV={envdir}
deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
+install_command = pip install -U {opts} {packages}
+usedevelop = True
commands = python setup.py testr --slowest --testr-args='{posargs}'
[testenv:pep8]