summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorTony Breeds <tony@bakeyournoodle.com>2016-12-13 15:27:09 +1100
committerTony Breeds <tony@bakeyournoodle.com>2016-12-20 14:34:24 +1100
commitb4bc985324061262c9c5f7f338691376e29a49a3 (patch)
treed02b01ac267e86bd55926970d3d8928afe16f2ff /tox.ini
parent2e89960017cc6715abb8132aab86da8568cda2bc (diff)
downloadpycadf-b4bc985324061262c9c5f7f338691376e29a49a3.tar.gz
Add Constraints support
Adding constraints support to libraries is slightly more complex than services as the libraries themselves are listed in upper-constraints.txt which leads to errors that you can't install a specific version and a constrained version. This change adds constraints support by also adding a helper script to edit the constraints to remove pycadf. Change-Id: I385d89d2ce2ecc85532f4acc31ff1c975a150178
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini7
1 files changed, 6 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index d3501f1..db7f7bb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,8 +1,13 @@
[tox]
-minversion = 1.6
+minversion = 2.0
envlist = py34,py27,pep8
[testenv]
+setenv =
+ VIRTUAL_ENV={envdir}
+ BRANCH_NAME=master
+ CLIENT_NAME=pycadf
+install_command = {toxinidir}/tools/tox_install.sh {env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt} {opts} {packages}
deps = -r{toxinidir}/test-requirements.txt
commands = python setup.py testr --slowest --testr-args='{posargs}'